Jump to content

Users - Manager field not displaying correctly


Cassie
 Share

Recommended Posts

It might be worth looking at the mapping in your Data Import configuration to check that something hasn't changed on the AD side and where this information is being stored in AD.  It would also be good to check if your Data Import tool is running on the latest version.

I'll keep an eye open for reports of this happening to other customers, but so far I haven't heard of any.

Link to comment
Share on other sites

Oh that's interesting I saw a couple of accounts earlier today like that and I thought someone must have done something wrong. I then corrected the issue.

We don't use Data import at all, but but we do create accounts automatically via the BPM and pulling the managers details after the user selects via Data Source pulling all users on the form. Then with the managers information to populate the New Starters Manager details which has been working. 

I was able to correct it manually via the User Account profile though but didn't think anything else of it at the time. 

Maybe something is up with the API? 

  • Like 1
Link to comment
Share on other sites

14 hours ago, Cassie said:

the correct information comes through, Hornbill no longer displays it correctly.

We can't share that information publicly, so could you raise a Support request with a Passcode so we can take a look and see where the issue is occurring, please?

Link to comment
Share on other sites

After a closer look and a little testing, I can see that a data issue can easily create this scenario.

The manager field is expecting the ID of the manager to be stored.  In the case where the manager field is not showing correctly, you can use Database Direct to look under the h_sys_user_profiles table and in the manager (h_manager) column this should be the ID of the manager, and not the full name, or anything else.  

image.png

 

This display of the last character of the managers name is simple to replicate, by importing the name and not the ID of the manager.

image.png

 

In cases where there are only a few accounts where the manager is not showing correctly, it might be that manager ID format is correct, but there isn't a user in Hornbill with that ID.

In cases where all the account records are like this, it is more likely an issue coming from the importing.  What I can't say at the moment is if this would be a mapping issue with the Import tool configuration, a defect in the Import tool, or a data change in AD.  A good starting point is to make sure that the latest version of the Import Tool is running.

  • Like 1
Link to comment
Share on other sites

Hi, it looks to be all users.

I can go in and edit and resave manager, this then displays correctly.

Once the import is rerun, it overwrites and the shows only 1 letter again.

We have just updated to the latest import and has made no difference.

Thanks

Cassie

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...