Jump to content

Reports failing with a "The maximum columns of 20 for this report has been exceeded. Requested number is 116"


Recommended Posts

Hi, is anyone else experiencing this with reports which were previously working up until yesterday?

Have encountered it on a couple of reports (both scheduled and manual) where reports which were working up until yesterday are showing as Failed and upon opening the csv/xls just get "The maximum columns of 20 for this report has been exceeded. Requested number is 116".

Admittedly the reports which failed are ones I inherited which export a lot of columns which we don't actually use in various daily/weekly/monthly reports (I doubt senior management care about the Activity Stream ID or the BPM ID columns somehow) so this is good motivation to pull my finger out and do some housekeeping to slash these reports back!


Link to comment
Share on other sites

@RobW @Dan Munns @HGrigsby This is a change that is covered in the latest ESP release notes:

  • Stops the system from processing the reports further when the maximum is reached and to return an error report as the output. Updated the HTML templates for the reports so that the error message can be produced and displayed.

Now I believe that previously these reports would fail silently, if you correct the column count to match the configured limit there shouldn't be a problem.

Link to comment
Share on other sites

@Deen same for us. Many reports that have worked fine for a number of years with over 20 columns suddenly don't work anymore. I cant find a place to change the column limit so assume that this is hard coded somewhere. 

This isn't a change in error reporting, it is a change of behaviour of reports. Can this be looked at urgently as I dont really want to have to create all our monthly ExCo reporting manually.

  • Like 1
Link to comment
Share on other sites

Thanks @Deen

Our reports now run.  We now have an issue where the reports fail when they hit 5000 rows, the report fails rather than stops at 5000 rows and ignores what we have set in api.xmlmc.queryExec.maxResultsAllowed  (25000)


Before these changes were made if the report was more than the limit it would return 25000 rows and stop, the current setting makes the report fail rather than collect 5000 and stop running.

Could you amend this setting too?



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...