Jump to content

On Hold Visability


Jeremy
 Share

Recommended Posts

We have some users that have the ability when putting a call on hold the default visibility is Owner when we have set it to be team, no I'm not sure if we have a rogue setting somewhere (screenshots below).

Also is there a way of turning off Owner visibility for on hold statuses?

 2019-10-23.png

image.png.52e620e9686847b36201dfaecc766c0a.png

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

We have some analysts who are seeing the default visibility as 'owner' when putting a call on hold or taking a call off hold, the default is set to 'customer' in the settings. I dont think its a browser issue as i got them to try in both Internet Explorer and Google Chrome and they got the same result. I also tried changing the default to 'team' in the settings but that didnt make a difference either. Are there any suggestions on what to do to resolve this?

 

Regards,

 

Daniel.

Link to comment
Share on other sites

  • 2 weeks later...

Hi @DFarran

Just wondering if you are using sub-statuses here?  If so then it could be the new visibility level against the sub-statuses that is giving that setting.  If you are using sub-statuses, then if you view the sub-status details you should see an option to change the default value e.g.

 image.png

 

Kind Regards,

Dave

Link to comment
Share on other sites

Hi @David Hall,

 

Thanks for the reply, I have checked and that drop down is blank for all of our sub statuses.Maybe the fact that its blank is causing issues? I could try going through and adding a default to each of them, the interesting thing is that the issue doesn't occur for me but I do have a few more permissions that others do so I'm not sure if that is also playing a part.

As a side note I removed owner from the setting mentioned by James earlier in the thread and the default visibility now goes to public for the affected users which isn't ticked, the only two options that are now ticked are Customer and Team.

Regards,

 

Daniel.

Link to comment
Share on other sites

  • 2 weeks later...

@DFarran

Apologies missed the notification of your last post.  

I've just posted this on another thread with a similar discussion ... if the hold action is being performed via a sub-status change, the process should follow that it will use this value if set, if no value is set here then it should revert back to using the previously mentioned app setting.

image.png

In the upcoming update of Service Manager we've made some back end updates to the operation that posts the timeline update, I've just checked it with this scenario and that is working as expected, so if there is still an issue it should be corrected in the next update > build 1805.

Kind Regards,

Dave

Link to comment
Share on other sites

Hi @David Hall

 

We have applied update 1805 but analysts still have the same issue. The first screenshot attached shows when one of my colleagues trying to change the sub status of a call, as you can see the default is 'Public' even though this isn't on the list. Whereas the second screenshot is when I try to change the sub status of a call, it defaults to team which is correct as per the settings. The only difference between us is that I have some extra permissions.

 

Regards,

 

Daniel. 

 

 

 

visibility.png

Link to comment
Share on other sites

@DFarran

Thanks for the update, having reviewed the code, it should default to the "highest" visibility level permitted on the request for the user, however if no levels are found it will default to "public".

Unfortunately I've not been able to recreate locally to this point, would you be able to post a screenshot/list of the servicemanager roles you have assigned to the colleague that sees this issue, I can then try to match the configuration and investigate further to see if I can pinpoint the issue.

Kind Regards,

Dave

Link to comment
Share on other sites

Hi @DFarran

I've been trying to replicate but despite having a configuration that looks to match yours I've still been unable to.  We've just pushed out a new update of Service Manager today, if you could confirm whether the issue still persists in the latest update that would be appreciated, if is then I'll look at some further steps to try to replicate.

Kind Regards,

Dave.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...