Jump to content

Lifespan Report

Gemma Morrison

Recommended Posts



I am trying to run a report for the particular catalog within our Service, however I have noticed after running the report a few times for various other catalogs, the report looks like they are capped at 5000...


is there anyway I can run a report from 05/06/2018 (our go live date) until present or will the report be limited to 5000 each time? which in that case I would then require to run each month and add the results together?

Link to comment
Share on other sites

@Gemma Morrison there are also additional caps that restrict how long an SQL query can run (usually 30 seconds).  This is to prevent a report from having a performance impact on the server.  As an alternative you may want to break the report into two 6 monthly chunks.

Link to comment
Share on other sites

Hi @Gemma Morrison Deen is correct, if a report takes more than 30 seconds to run it will fail, so not to impact performance on your instance. 

You can however tweak / play with the max rows which can be output in a report (up to a maximum of 25,000 rows) from the following system setting:

Home > System > Settings > Advanced in the admin console

The default is 1,000 rows but it looks like you have this set to 5,000 already, but it can go to 25,000, but only if this does not exceed the 30 second max when run, as it will then timeout.





Link to comment
Share on other sites

  • 6 months later...

Hello all,

I appreciate this was 7 months ago, but we are encountering issues with reports at the moment.

Having been directed by my team to do so, instead of running a report for a full year as I would previously have done, I tried doing it in six monthly chunks. This didn't work, and so I tried 4 months / 3 months / 2 months and finally back to 1 month. The only report that has worked on our instance is the 1 month which  has taken 30 seconds exactly to run.

All other time periods are showing as blank once 'run'.

I wonder if our problem could more be about the amount of time a report is taking to run, rather than the cap of data lines? Previously, our reports on average took 8-10 seconds to run whereas they are all taking 30 seconds to run now.

Could this be down to our upgrade to Windows10 and the Cloud? I'm not sure if this would have an impact on the system writing reports to work with the newer excel?

Hope this all makes sense, let me know if you need any further information :)


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...