Jump to content

Updating Status and Sub Status in BPM not doing the latter


Recommended Posts

I have currently trying to update the status and sub-status of a request from the BPM. The BPM node Update Request > Place on Hold is working fine and selecting the correct sub status on the request. 

However when I use the Update Request > Status node and specifying both the status and sub-status, only the status value is updated and no the sub-status. I checked that it is not a screen refresh issues, like the known issue with putting requests on hold via the BPM, as it is not reflected in the database either.

opensub.JPG.3e247880855d5084e4c541e3cf4ee2f8.JPG

Cheers

Martyn

 

Link to comment
Share on other sites

Hi @Martyn Houghton

I've tried this out locally and it seems to be updating as expected for me.  Do you know if there were any errors in the serverservice log file at the point at which it tried to update the sub-status?  Alternatively if you can let me know an example time of when you tried this I can have a look in the log file for you.

Regards,

Dave.

Link to comment
Share on other sites

Hi @Martyn Houghton

No errors in the logs, but I've just been trying again to replicate and I've identified the issue locally, it was an issue with the logic when you are updating from "New" to "Open" status.  I've implemented a fix and that should be available in the next service manager update.

Regards,

Dave.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...