Jump to content

BPM fail to assign to team


J_Tamburrini
 Share

Recommended Posts

Afternoon All,

does anyone else get the following error> the bpm was working on Friday but fell over on Monday?

image.png.64fd010a701e7b36daf876b5f099867b.png

So from the start fo the process

 

HR  email over the forms ,The forms are setup in the routing rules to log a new SR in the staff administration group/Team.

The BPM is set out as per below,

image.thumb.png.ea68aac9b903fcd19f29237f015a9bf8.png

image.png.ac936ca140f3b29d76e8cdcdf93854f3.png

 

It crashes out on the assign part regardless of auto or manual. again worked fine on Fridays UAT

image.thumb.png.4c83c1e45c77b62763717ccfbbe1b865.png

Link to comment
Share on other sites

i tried to set to manual assign on both and i now get an error BPM process failed to restart

 

Xmlmc method invocation failed for BPM invocation node 's1/flowcode-5c76dc03-4bea-e702-2aec-f7d506ac8046': 0200 apps assignTeam FlowCode Exception (com.hornbill.servicemanager/entities/Requests/fc_bpm/assignTeam): Input parameter validation error: The element <accessToken> was not expected at location '/methodCall/params/accessToken'

Link to comment
Share on other sites

@J_Tamburrini changing process configuration does not affect existing requests. When a request is created a "copy" of the proces definition at that time is created (called process instance) and this process instance is associated to the request. Restarting won't pick up changes in configuration either as the "restart" will still use the process instance created for that request.

The reason why the process failed there was because of the "Team" parameter set to auto. I can have a look and have this request fixed if you like though...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...