Jump to content

Adding new connections during incident creation process


Recommended Posts

Hi,

I am trying to update a catalogue item so that when end users log an incident through that item, they are able to add connections (everyone is internal) to the incident. From the end users point of view, this is working as expected and all the data is captured during the progressive capture. What I've ended up with, and can't seem to get past is the following:

1251952255_2020-10-0516_33_16-Window.thumb.png.1a55016984831a1a450db733b9e9d480.png

I am not sure how to get the connections to show properly. Bellow is a snippet of the underlying Progressive Capture:

 1300206163_2020-10-0515_51_54-Window.png.a1d9b1a39d043392683be48f2caa0adb.png

The Connections Required1 has a simple Static Radio set which is used to select the appropriate connection. The Impacted/Interested Users both use a data query search for the end user to select from:

123950090_2020-10-0515_56_36-Window.png.f2d56a40e453bcb1a685b1d36d6904ad.png

In the corresponding Business Process flow, I have the setup below:

1593162653_2020-10-0516_04_04-Window.thumb.png.1a67524133f38a80cc42b57e41200d11.png

 

Is anyone able to shed some light on what I am doing wrong? I've tried Inject and Override both display and raw data values. I found the following post after I set all this up, and can see it working there, however I don't know how the data was originally entered into the newly created fields in the service portofilo: https://community.hornbill.com/topic/16248-connections/?tab=comments#comment-78537

Thanks

James 

 

Link to comment
Share on other sites

Hi @James Gallally

Thanks for sending me the definition of your BPM.
The reason you get the "blank" connection is because it hasn't been able to find the user it was supposed to associate. For connections to work it requires the User ID - and if you are passing values directly from the Progressive Capture from a Coworker data provider, the User ID is the Raw Value so this is what you need to map when setting up your BPM. 

At the moment, you are passing in the display value - which is the users display name (e.g. Bob Dickinson, rather than BobD). 

So for example where your string currently is:
&[functions.pcf("userconnectionsinterested4","field_1")]

It needs to be:

&[functions.pcf("userconnectionsinterested4","field_1_value")]

I was able to replicate your issue simply by uploading your BPM in it's current state - but after adding _value to some of the "Add Connection" node mappings for a test, it fixed the problem. 

I see you mentioned you had tried this - but could you try it again, and have another try? If it still is failing for you after updating all the nodes, please feel free to send me the updated definition and I'll take another quick look.

Kind Regards

Bob

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...