Jump to content

Minor UI issue/confusion/enhancement - URL links in Stage Notes paste as active but then lose active hyperlink after reload


Recommended Posts

I went through all my BPMs and updated a stage note to refer to an O365 document with all the custom fields documented.

When I pasted the O365 doc link into the Stage Note it resolved immediately as a hyperlink (blue/underlined); but after saving and then re-opening, the active link is gone. it 'survives' a save operation within the session but not the reload.

I don't know what was intended in the design here so I don't know whether I am reporting that the hyperlink is not persistent when it should be or the browser is recognising a hyperlink when it shouldn't. Either way, it's just annoying that it does one thing and then loses it.

It would be very handy if we can have active hyperlinks in Stage Notes because mine got so large I needed to use the notes to refer to external online documents.

This is what it looks like after pasting and it was handy; you can see the blue link and it's active when clicked:

image.png.de036dafadbf46274f7d7a595ab8aec4.png

And this is now what I have to paste (full URL as text) which is a bit nasty:

image.thumb.png.6e39604b3d42fbae3ff9b3c682954b73.png

Link to comment
Share on other sites

  • Berto2002 changed the title to Minor UI issue/confusion/enhancement - URL links in Stage Notes paste as active but then lose active hyperlink after reload

Hi @Berto2002

By just typing in a url into the Notes box you will see that this does not get resolved as a url and is not a clickable link. 

image.png

 

Using the Share option in SharePoint and then getting a copy of the link does result in what you have shown in your screen grab, but at no time are you able to click on it to open up the file, even before saving the workflow.  The notes are really just provided for some simple text based notes.  If you try to copy and paste a link from your browser URL field for this same file, you will see that it doesn't work.  I'm not sure how the browser is interpreting this as a link when using this Copy option on a SharePoint file, but as it is displaying the file name, the Copy feature must be wrapping it some extra code to get it to display like this.

image.png

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...