Jump to content

SQL Database Direct Output too small


samwoo
 Share

Recommended Posts

Hello,

On Chrome, Edge and IE11, the SQL Databaase Direct output window is too small... i can barely see the headings. I pressed F12 to see the Developer Console and I can see that the Max-Height is set to 26.62px. If i change this in the Console to 260px as a temporary measure, I can view the output.. until I change the tables

<div class="table-responsive ng-isolate-scope" style="position: relative; overflow-x: scroll; max-height: 26.62px;" resize="" offset="vm.model.tableOffset">

I've not updated the Service Manager, and I have not been in this area of the system since before the Automatic Update that happened a few days ago.

Can this be looked at?

Thanks,

Samuel

Link to comment
Share on other sites

46 minutes ago, TrevorKillick said:

Hi Samuel

There are two button in the top right that allow you to hide the query input and the list of tables, giving you more space to view the table data.

Kind Regards

Trevor Killick

Screen Shot 2017-02-02 at 12.25.06.png

Hi Trevor,

Thanks for responding. That has helped, cheers! Is there any reason why it doesn't work now like it did before?

Thanks,

Samuel

Link to comment
Share on other sites

Hi Samuel

Not sure what you mean by as before? This current behaviour has been in place since Admin 2.0 was rolled out last year, the height is set so that the page only takes up 100% of the viewable space and then inside the table can be scrolled on the X and Y access on overflow.

Kind Regards

Trevor Killick

Link to comment
Share on other sites

2 minutes ago, TrevorKillick said:

Hi Samuel

Not sure what you mean by as before? This current behaviour has been in place since Admin 2.0 was rolled out last year, the height is set so that the page only takes up 100% of the viewable space and then inside the table can be scrolled on the X and Y access on overflow.

Kind Regards

Trevor Killick

Hi Trevor,

Last week or a couple of weeks ago, i was running SQL in Database Direct and was able to scroll down and see the output without having to click the button to hide the SQL bit. It showed regardless of whether I select 25 rows or 2000 rows and was quite useful.

I know because I was showing one my colleagues how to save the SQL code I sent her into her Database Direct List and we were able to see the output by scrolling down on both of our machines in IE11.

Today I couldnt see it the same way I did then.

Thanks,

Samuel

Link to comment
Share on other sites

@samwoo

Ok so it looks like we added a change for Sticky Table headers so like excel you can scroll the data and maintain visibility of the header row, we will take a look at correcting this as its broken in IE11, apologies for this. I will post back when a fix is available.

Kind Regards

Trevor Killick

  • Like 1
Link to comment
Share on other sites

The sticky headers in not the issue. The resizing and scrolling of the table is handled by a 3rd party table ui and this has not changed. It appears to work fine on IE11 (and others) in test environment, The table adjusts height based on its top position in screen and the bottom of the screen and the scrolling seems to be in order. 

@samwoo is your browser running in compatibility mode just out of interest?

 

Cheers

Capture.PNG

Link to comment
Share on other sites

6 hours ago, NeilWJ said:

The sticky headers in not the issue. The resizing and scrolling of the table is handled by a 3rd party table ui and this has not changed. It appears to work fine on IE11 (and others) in test environment, The table adjusts height based on its top position in screen and the bottom of the screen and the scrolling seems to be in order. 

@samwoo is your browser running in compatibility mode just out of interest?

 

Cheers

Capture.PNG

Hi @NeilWJ,

Thanks for responding. I certainly do not have a resolution such as the one in your screenshot, mine is 1366 x 768. IE11 doesn't have compatability view enabled for Hornbill.

The more I think about it, the more I'm wondering whether or not I actually used a monitor the last time I ran the SQL Database Direct (1920 x 1080).

I understand that the screen fits to 100% the width and height of the visible screen, and with the SQL input element a fixed width, this would explain why I don't see the results of the SQL below.

At the moment I am using Edge and this is what I see.
58943f2dd30eb_HornbillWindowSQLDirect.thumb.png.035123b81ebcbcf7e7e4f10d2a217b96.png

If i were to zoom out in edge from 100% to 75% it is jut about useable. For now this could be my temporary workaround... until I next have a monitor available to use.

Sorry to have assumed there was something wrong with this area.

I am curious though to how many people are still using these resolutions with Hornbill.

Thanks,

Samuel

Link to comment
Share on other sites

Hello,

I just went into Database Direct on Microsoft Edge, I can now view the entire output (the amount of rows I selected).

When I first created this post, it wasn't working in Edge the way you see it on my screenshot (see extended scrollbar), and now it is. Something changed?
589a02a9c2553_ExpandedResults.thumb.png.abe7189d1959900f94b6230cf39bd843.png

Thanks,

Samuel

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...