Jump to content

Multiline Formatting and Text Box not resizing automatically


samwoo
 Share

Recommended Posts

Hello,

When I need to provide certain information to the customer via the Self Service Portal, I often use the Multiline Text-box and set it to Read-Only and input the information I need to relay as the Default value. This is great except for two things...

  1. When having large amounts of information, the formatting of the Multiline textbox (as users have found) can be difficult to read. Could we have the possibility of adding formatting to this box? At least allowing line breaks via the PCM setup to show in the form as expected.
  2. When anyone jumps to a form with Read Only information, the field is automatically too large. We need this Multiline text box to fit to the text automatically. If i zoom in and out whilst on this screen, the Multiline text box shrinks to fit the text... which is not a workaround but to show that it seems to be capable of doing this.
    LargeBoxBeforeZoom.pngLargeBoxAfterZoom.png

Thanks,

Samuel

Link to comment
Share on other sites

  • 2 weeks later...

Hi @samwoo,

I think we found solution for your problem. Current implementation is displaying disabled multiline control when is set to read only mode (left side of progressive capture) - so you can see your text exactly like you typed it there. With new change it will be displayed the same way as it is on right side of progressive capture - but only if READ only attribute will be set.

So the result will be like on screenshot attached below.

 

pg-cf-textarea.png

Please note that this should also solve your problem described in post: 

You can use regular wiki formatting markup to format your text and create links if needed.
 

Kind Regards,
Miro

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

I really like how it looks now, and the Wiki Markup is a plus!

Is there a way to do line breaks in the Markup? I've got an image in the progressive capture that is smallish, but the first word of the text in the paragraph following the image is showing on the same line as the image itself.

What's the workaround to ensure this paragraph is on it's own line?

Link to comment
Share on other sites

4 minutes ago, TrevorKillick said:

Hi Samuel

In Wiki Markup you should be able to use * it must be on a new line without a space before it and with a space after it.


Kind Regards

Trevor Killick

Thanks for the response I shall try that, though I cant seem to be able to add a new line as the input box for "Default Value" is a one liner. I remember there being a feature where you could CTRL click in that box to bring up the Multi-line editor but I dont think thats been implemented yet?

Is there a Wiki-Markup code for line-breaks as there is nothing on the Wiki about it?

Link to comment
Share on other sites

29 minutes ago, TrevorKillick said:

Hi Samuel 

I will raise this with development, there is no wiki implementation for line break at the moment but the default text should be multiline. 

Kind Regards

Trevor Killick

Hi Trevor,

Appreciate this thanks. I've just checked and yes the "Default Value" is already Multi-line but it's not working with some of the Wiki formatting.

[[LINK]] works, as does '''BOLD''' and ''italic'' but the others dont work (numbered lists, bullets, the headings also seem to play havok with the overall formatting as well as when you start a bit of text with an = you cannot close it with and = as it formats all the text after it)

Cheers,

Samuel

Link to comment
Share on other sites

  • 4 months later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...