Jump to content

Recommended Posts

As it is possible to customise the branding of both the Service and Customer Portals, including using a link to you own logo, can the login page on the Service and Customer Portal inherit the logo link from the appropriate portal customisation setting rather than displaying the Hornbill logo?

Cheers

Martyn

Link to post
Share on other sites

Hi Martyn

Customising the Login Page has never come up, we have a story in the Backlog (CH00138704) for the Portals to improve how its customised and expand the options i have added the Login page to this as its more than likely that customers would want to change more than just the logo.

Kind Regards

Trevor Killick

Link to post
Share on other sites

Trevor

Thanks for adding it too the story for the Portal Customisation options. As part of our initial implementation, we are just looking at the main touch points are external and internal customers will see when accessing the self service.

Cheers

Martyn

Link to post
Share on other sites

Hi Martyn,

In addition to this there is a video that is available that shows some of the settings that you can apply to the portals. This includes changing the Hornbill logo to a custom logo. https://youtu.be/_I1m42uX0cM. The video is looking a bit dated so you may find some of the settings and layouts have changed since it was recorded.

Link to post
Share on other sites

James

Thanks. We customised the main elements of the portals, it is just that when you click on the login page for an external customer to enter there login details you then get the Hornbill Logo, not your customised one you have specified and displaying in the main portal screen.

Cheers

Martyn

Link to post
Share on other sites
  • 6 months later...
  • 1 month later...
  • 4 months later...
Guest David Calder

I assume this has been asked for before, but it would be really good if we could upload the images for the Logo and the Home Page Image to our instance, instead of linking to a remote source.

Our corporate site is http only but a https link is required. Our customer site is https but is locked down to prevent linking from third parties.

I would also argue that any external site where I host my images could be considered an IT Service and if that is unavailable then the logo isn't going to show on the Portal.

Link to post
Share on other sites

@David Calder

You can use a http:// image in the advanced settings

Just be aware that if you make changes under Home>System>Manage Portals that it will NOT let you save the changes with a http:// image selected.

I just add https:// and save and then change the settings back under advanced settings.

The setting is:

guest.anonymous.servicePortal.core.style.image.logo

 

[EDIT:] Just FYI, I host most of our images on our iis server. The images won't show outside our domain but show fine internally.

 

  • Like 2
Link to post
Share on other sites
  • 3 weeks later...

@James Ainsworth @TrevorKillick

Just wondering if there us any update on the ability to replace the Hornbill logo displayed on the the Customer Portal Logon Page with our own?

We are now testing using our own custom domain proxy to the customer portal and have updated all the other parts of the customer portal to use our branding/logo's, its just the Login page that breaks the formatting/branding displaying the Hornbill Logo.

Cheers

Martyn

Link to post
Share on other sites

Hi All

The ability to show your custom logo as part of the login screen has been added once its available on live i will post back with a response.

We are still looking at adding the uploading of images for customising the portals so you do not have to host publicly https images, once i have further information on this i will provide a response.

Kind Regards

Trevor Killick

Link to post
Share on other sites
  • 3 weeks later...

I'm pleased to let you know that this feature is now available.  This uses the existing option for setting your company logo on the main portal landing page.  You may find that if you already have a custom logo set up here that this will automatically apply to the login page so you shouldn't have to make any changes.

customloginlogo.PNG

 

Regards,

James

  • Like 2
Link to post
Share on other sites

Hi @James Ainsworth,

Thank you and the team so much for making this possible!

Two things that jumped out at me:

Curious to know if others are seeing this behaviour as well.

Have a nice evening,

Alex

Link to post
Share on other sites

Hi @Alex8000

Thanks for the feedback, sorry for the omission, we should have checked that too, the problem is that code is part of our framework for dealing with SSO and as such is shared between all of our web interfaces so we have to change this with caution.  We have raised a defect internally and will get that looked at soon. 

Gerry

Link to post
Share on other sites
  • 3 weeks later...
On 4/18/2017 at 9:51 PM, James Ainsworth said:

I'm pleased to let you know that this feature is now available.  This uses the existing option for setting your company logo on the main portal landing page.  You may find that if you already have a custom logo set up here that this will automatically apply to the login page so you shouldn't have to make any changes.

customloginlogo.PNG

 

Regards,

James

Would it be possible to provide functionality for uploading a logo in stead of providing a link? In the same way as you can do with Bulletins/Banners.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...