Jump to content

Intelligent Capture - Enable Autocomplete (turned on by default)


Recommended Posts

Good afternoon,

For quite some time now, we've been having a number of issues where people are logging tickets, and initially logging them correctly, but when the ticket is logged, some of their data has changed to what they initially inputted.

Over time, it appears to that the "Auto Fill" functionality, especially in Edge, is the culprit. This affects Text and Date input fields in the intelligent capture form.

As a result we are having to cancel the ticket and ask people to log it again but to carefully check the fields as they progressed through the forms.

We had an incident recently where a Leaver was logged and the person logging it has accidentally selected the person's name in another field, and because Auto-Fill can deal with multiple fields, it amended that person's Leaving Date to March, when August was selected initially. This led to the Service Desk to process this person as a Leaver who has already left, and that person lost their access (for a very short time, thankfully this was picked up and sorted quickly).

We cannot disable this functionality across the entire organisation, and Edge doesn't allow disabling "Auto Fill" on a per-website basis, so the only options that came to mind were:

  • On forms with sensitive fields, add a question to each page prompting the user to say they have checked the input fields
  • Discuss any potential solutions with Hornbill.

I opted for the second option as I had a browse on the web to see if HTML has the capabilities to disable "Auto Fill" when I came across the autocomplete attribute:
https://www.w3schools.com/howto/howto_html_autocomplete_off.asp

If this disables auto fill on any input fields then I would like to raise the following enhancement:
_____________________________________________________________________________________________________________

Enhancement Request:

For all input fields in the Intelligent Capture designer screens, please add the option "Allow Autocomplete" (enabled by default). If disabled, then it will add autocomplete="off" to the input field in the HTML. This should allow any user-defined as sensitive input fields to not be impacted by any Auto-Fill.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...