Jump to content

analystUpdateFromEmail not generating emails


JanS2000
 Share

Recommended Posts

Morning, I don't know whether I'm missing something or if there's a config change required, but I've been told that colleagues don't receive email notifications, when calls in their queue are updated via email. The setting as I understand it, can't be changed and it's turned on by default. It's never worked and I just thought that was normal, as we get the notifications in the app, however, for our mobile technicians it would be helpful for them to receive email notifications about their requests. I'll be testing the mobile app along with one of the technicians in the coming weeks, so we may not need this function long term, but I'd like to get to the bottom of why it doesn't work, as it would be helpful to the other teams that use the application.

guest.app.requests.notification.emailTemplate.analystUpdateFromEmail

>The email template to be used when sending an email to the analyst for request updated from email
AnalystUpdateRequestFromEmailNotification
 
I've noticed as well, that I don't receive emails for my scheduled reports, I still have to go into reports and download the report from the history tab. As far as I know, all other email notifications work okay, including emails to customers when we update their request when visibility is set to customer.
 
Any advice would be much appreciated. I'm not sure if this is a fault that I need to raise with support, but thought I'd raise it on here first. Thank you.
Link to comment
Share on other sites

44 minutes ago, JanS2000 said:

guest.app.requests.notification.emailTemplate.analystUpdateFromEmail

This setting can certainly be changed, but this is the email template that is used, not the setting for whether emails are sent or not.

If you review the values for the settings that begin: guest.app.requests.notification.notificationType these can be set to hornbill-only, email-only, both, or none, and the guest.app.requests.notification.allowUserDefinedNotificationType setting determines whether analysts can alter their personal notification settings.

Link to comment
Share on other sites

2 minutes ago, Steve Giller said:

This setting can certainly be changed, but this is the email template that is used, not the setting for whether emails are sent or not.

If you review the values for the settings that begin: guest.app.requests.notification.notificationType these can be set to hornbill-only, email-only, both, or none, and the guest.app.requests.notification.allowUserDefinedNotificationType setting determines whether analysts can alter their personal notification settings.

Hi Steve, thanks. I checked that and changed a couple of notification types to both, I'll check this one though and make sure that's set to both as well.

Link to comment
Share on other sites

Hello again, I checked this setting and found it was already set to both but it's not generating the emails. Should I raise this with support?

Another question related to this, does the email analyst notification work if anyone other than the named customer, emails in with an update about a request, or does it only send the notification when the customer themselves emails? It's just I've got one in my queue that someone else has emailed in about (from a different department), and I haven't had a notification by email. Thanks.

Link to comment
Share on other sites

Morning, the notifications seem a bit hit and miss in general - the email update from user definitely isn't working, but is enabled, but I've also noticed that we don't always get updates in Hornbill for updates made on our requests either. I've checked my own notification settings and they're all okay from what I can tell. 

 

image.thumb.png.61b61d1d8632f6444720c60c56c72b61.png

 

Scheduled reports don't come through via email either, they're available to download, but I have set them to send me an email, but it hasn't worked since we started using Hornbill. I haven't really had time to dig a bit deeper till recently and realised. If needed, I'll raise this all with support, but if anyone has any ideas on this where I might be going wrong, please let me know. Thanks.

 

Link to comment
Share on other sites

1 hour ago, Steve Giller said:

This looks like it could be an email setup problem, as there are two separate areas and both issues are Users not receiving emails.

Have you reviewed the Email Notification Prerequisites on the Service Manager Notification Settings page to ensure the settings are correct?

I'll have a look at that now, thanks Steve.

Link to comment
Share on other sites

  • 2 weeks later...
On 10/14/2022 at 11:41 AM, Steve Giller said:

This looks like it could be an email setup problem, as there are two separate areas and both issues are Users not receiving emails.

Have you reviewed the Email Notification Prerequisites on the Service Manager Notification Settings page to ensure the settings are correct?

Hi @Steve GillerI checked the prerequisites and I think they're okay, I'm not 100% certain what they should be though. Other email notifications work, it's the reporting and customer email updates that don't work (that I'm aware of at least). image.png.f4ff4b0f5a8234711d8b415e76fee142.png

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...