Jump to content

Update Service Status error message I cannot work out


Berto2002
 Share

Recommended Posts

I used this node to try to update the service status:

image.thumb.png.916e3b474f9f27556d2f068b6d0944c9.png

But it gave this error and I don't know what that means. I tried shortening the length of the message, removing the variable for request ID, entering a hardcoded Status but nothing worked. In the end I only got it going by changing the node to a timeline update.

 

4.785457s INFO Process Flow Transition from 'Email Start to ICT Chg Notifs' (id=flowcode-854ae9bb, type=HornbillAutomatiomn) to 'Update Service status text that Change is in progress' (id=flowcode-41ee5f38, type=HornbillAutomatiomn)
4.837788s INFO Execution Step: currentStage='stage-c05af8e7', currentNode='flowcode-41ee5f38', suspended='false'
4.837995s INFO Unsuspending process at node 'Update Service status text that Change is in progress' (id=flowcode-41ee5f38)
4.882780s ERROR Execution Failed: Xmlmc method invocation failed for BPM invocation node 'stage-c05af8e7/flowcode-41ee5f38': <methodCallResult status="fail"> <state> <code>0200</code> <service>apps</service> <operation>reqServiceUpdateServiceStatus</operation> <error>FlowCode Exception (com.hornbill.servicemanager/entities/Requests/fc_bpm/reqServiceUpdateServiceStatus): Input parameter validation error: The element &lt;serviceStatusMessage&gt; was not expected at location &apos;/methodCall/params/serviceStatusMessage&apos;</error> </state> </methodCallResult>
4.978548s INFO

Workflow processing complete

Link to comment
Share on other sites

I will try this on a fresh workflow. I did try that on a restart of a failed one but it did not work.

I suspect there is an issue with the code behind the save/restart on failed BPMs. I need to test more. My hypothesis is that:

  • If there's a failed BPM and you edit something and try a restart but it doesn't work
  • No subsequent fix to that open instance of the BPM edit will work, particularly if the error received on restart was the one that says, "nothing changed do you want to force save"
  • You need to close and re-open the BPM in the browser to make each subsequent edit/fix attempt
Link to comment
Share on other sites

@James AinsworthI have found that if you have a failed BPM and you go into the instance and try to edit it and have an unsuccessful restart attempt then under certain circumstances even if you subsequently make the correct adjustment to the BPM and attempt to restart it it still won't work, giving you a false impression that even a correct fix won't get the BPM working again.

Steps to reproduce:

  1. set up a workflow node to update the service status of the service under which a request is logged (service manager> entity> requests> request service> update service status), leave the request ID to auto and leave the status to auto and enter a manual status message. I.e. this is a deliberately incorrect configuration
  2. the workflow should fail with the following error message: "Xmlmc method invocation failed for BPM invocation node 'stage-c05af8e7/flowcode-cc529501': 0200 apps reqServiceUpdateServiceStatus FlowCode Exception (com.hornbill.servicemanager/entities/Requests/fc_bpm/reqServiceUpdateServiceStatus): Input parameter validation error: The element was not expected at location '/methodCall/params/serviceStatusMessage'"
  3. open the failed BPM and edit the (manual) status message text and then save the edited BPM. Attempt a restart of the process (the request is still stuck and you get a message "nothing changed, nothing to write to the database")
  4. Repeat step 3 and this time (emulating the administrator trying something else to get this working) on save you will get "Validation failed when saving. Would you like to skip validation and force save?" Click 'yes'
  5. now pretend you have had a realisation about how to really fix this and also the status to manual and select one of the values such as "available". When you press save, you get an error message again, "validation failed when saving. Would you like to skip validation and force save". And when you click yes and restart, even though you have successfully created a fix for this failed workflow, the ticket will not restart. This is the issue; i have applied a correct fix but it is not recognised due to the previous incorrect fix/error message
  6. close down the tab in which you are editing the BPM and then reopen it and you will find that the status edit that you thought you had made was not saved after all (in this instance it would still say auto and have no value).
  7. you can now, in this fresh instance, edit the status to be manual and select a value save and restart the BPM successfully

In short, either globally or in our instance, an incorrect fix to a broken workflow that results in the "forced save" error then prevents a real fix being applied until the editing session is terminated and restarted.

From my perspective it looks like two things could be happening here:

  1. perhaps when the message pops up about a force save it is not actually saving anything even if you click yes
  2. under circumstances when a material change has been made by the user, the system is incorrectly flagging that no change has been made; but this only happens if it follows a previously unsuccessful update.

I have logged this with Premier Support but because this is actually not stopping me (I have a workaround and it's a very edge case), I'm not sure the team will be able to prioritise it.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...