Jump to content

Invalid Date on "Find Time" BETA


Recommended Posts

Service Desk team found a new interface for the activity creation and they're unable to create activities as when a date time is selected the field change to Invalid Date.

With the admin user this issue is not shown and I'm able to create activities. There's any change on permissions we're not aware of? 

 

Adding some screenshots from Service Desk team:

 

 

MicrosoftTeams-image (4).png

MicrosoftTeams-image (3).png

MicrosoftTeams-image (2).png

MicrosoftTeams-image (1).png

  • Thanks 1
Link to comment
Share on other sites

@James AinsworthMember of our admin group reporting we are experiencing a similar error to this in Live.  I have asked her to demo it for me tomorrow morning EST.  Will report back my findings if/when we can reliably & repeatedly demonstrate the problem.  She is getting an error when choosing dates, keeps telling her invalid date no matter which date is chosen. 

Link to comment
Share on other sites

From what I gather, there might be an issue where certain users have specified a date/time format within their profile where the format shows time first and then date.  A possible temporary fix for this is for the affected user to change their date/time format on their user profile (or and admin to change this on their profile) so that the date/time format has the date first followed by the time. 

image.png

Link to comment
Share on other sites

Hey have tested, the date is still a issue on our side for a few reasons,

When we try to change the time in the field it shout that its a invalid date:
image.png.3778a9e403e7b54a6f77e2912bb674e4.png

Secondly when we submit this it has a null date in the questions field:

image.png.a009edffd9eafe5d89b4289d061da701.png

Thirdly its adding a hour to whatever time we do put in the field:

This was logged to say 12pm 

image.png.7de1c56504d6d0f74e2d47e87c555c9b.png

Also when we are trying to use the fields in our task its not pulling the dates through for proposed date anymore:

image.png.33b04a69d97eac412b52e75c41a6748f.png

so when we select use proposed dates on the task its not putting them in the change calendar as it was previously 

image.png.13f86bad5a77f277daba2d6cd2f3779c.png

so quite a few issues! 

H

 

Link to comment
Share on other sites

Hi @yelyah.nodrog

Can you change the date you enter to "31/03/2022 16:00:00" or "31/03/2022 04:00:00 pm" - I guess that problem could be wrong format as 16:00:00 as already indicating PM.
If possible please write here if it help.

Thank you,
Miro

Link to comment
Share on other sites

@Miro I'm not sure I follow what your asking?, Previously the date field used to come up in a separate box but that has obviously change with the new updates, but now whenever we try to change the date it shouts its invalid.

Are you saying I have to now put the dates down in 24 hour clock times? I cannot educate all users on the system to know that to get the system to capture the right date though?

H

Link to comment
Share on other sites

Hi @yelyah.nodrog

You shouldn't have to change to 24 hour clocks.  I believe what was mentioned in the earlier post is that somehow, a combination of 24 hour and 12 clocks has been allowed, when it shouldn't.  So, for example, even though you might use a 12 hour clock the PM or AM  may not force a selection when needs to be provided.  If you are using 24 hour, the PM  or AM shouldn't be used, but they may be available to be applied.  This mix of 12h and 24h may not be something caused by a manual entry, but it is also possible that one of the automations have put it into the date field incorrectly.  

I'll continue to investigate and also let you know if I hear of any updates from development.

  • Like 1
Link to comment
Share on other sites

Anyone else having trouble using the new date picker

image.png.0965b8b58e3d2ae097511995e564f615.png

 

When I try and go forward a month (eg. to April), the form move forward (like I've pressed Next), and if I try and go back a month the form moves back (like I've pressed Previous).

Nasim

  • Thanks 1
Link to comment
Share on other sites

Hi @Miro, Our Date and time fields were giving us Invalid Date no matter what manual dates we entered or selected from the calendar.

I have changed my date format from HH:MM TT MMM DD YYY over to MMM DD YYYY HH:MM tt and now the time value is being accepted. Is there a way to make the Time first version work? we prefer the time first format.

 

We are still having the issue where, for out Date picker in Intelligent Captures, the date recorded is a day prior to the one selected. (and the date in the side panel is 2 days prior)
 

  • Thanks 1
Link to comment
Share on other sites

Ok I've found out a bit more about my issue, when pressing next month form move forward (like you pressed next). This seems to happen on the progressive capture forms where the date is the last field. I've added another question/field and the behaviour has stopped. 

This is still a defect, although I have a workaround, that needs to be investigated.

Link to comment
Share on other sites

We are also having problems with dates and times on various progressive captures.

Any news on when this might be fixed?  I have people trying to book car parking spaces for the office opening next week.  I have some getting messages saying this day is not allowed, when trying to book for tomorrow 1/4 (it is) or if they select 4th April it puts in 4th May.

 

Helen 

Link to comment
Share on other sites

An update to the platform has just been released.  An additional patch is being scheduled to follow shortly.  The update provides fixes for all of the known issues except a time zone issue which is being provided in the patch that will follow the update.  

 

  • Like 1
Link to comment
Share on other sites

Hi 

I am still getting the issue where it jumps a month ahead when you select a date

Trying to pick tomorrow I get this

image.png.e234ac1ba2d12a08cde4d7ecf60f6bb4.png

And selecting the 4th April

image.png.af44e51f5632fa14d6e8fd8eb03e9d4e.png

I think because it is jumping a month ahead it thinks the 1st is a Sunday  

If you go back and try again it does then go to the right month or day but I have logged a support call because this is causing a problem as there are lots of parking requests coming in today.

Link to comment
Share on other sites

Hi @HGrigsby

While you are in discussion with Support, could you also try clearing your browser's cache?  Normally the cache is managed and clearing your cache shouldn't be needed, but I have seen times where for some reason or another, the cached files haven't been updated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...