Jump to content

Adding roles to users via the BPM


Jeremy
 Share

Recommended Posts

I have been trying to set up a process where people can request new accounts to be set up in Service Manager, this works and I can make the user an 'User' in the system, but when adding any roles they do not seem to be actioning that part of the bpm to add the specific role. Also I am finding adding the person to a team is not working also, what am I doing wrong?

Node for adding a role:

image.png.845d25e6747d1122017e259bfbdd1c20.png

Node for adding a team:

image.png.870b7e6cd6f60e184e424b1917e36528.png

This is taken from a simple list of all of our teams:

image.png.98fd43686a8d2b3e9bb0a7a694b9dc75.png

Link to comment
Share on other sites

@Jeremy not sure what to say about the Add Role.. I don't see any issues with it... can you confirm the user ID for the node is a valid user ID? For the Add To Organisation, I believe the node needs the Organisation ID as the value for the parameter (might need the URN, not sure)... perhaps in the simple list, change what you have for "Value" and put the organisation/team ID there. Make sure you reference this in the node, and not the display value.

Link to comment
Share on other sites

For the add role the user ID is correct, this is the similar to the making the person a 'user'

When you do this manually you have to refresh the page before adding roles, after making the person a user do we need a 'get role information' node? As there account has been updated and you can't assign roles to basic users, so have to update the BPM first?

I will look to find the URN for the teams and try that

Link to comment
Share on other sites

1 minute ago, Jeremy said:

I will look to find the URN for the teams and try that

I would say use the team ID first... then we can try the URN...

2 minutes ago, Jeremy said:

do we need a 'get role information' node?

There is no such node. I have tried the add role node yesterday, adding the "Collaboration Role" to a user and worked just fine... perhaps there is something else that is not working quite right there...

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...