Jump to content

Names missing from the user search on Employee Portal


Recommended Posts

Hi

We have an incident open for this already, but I'm just checking whether the 'fix' shown in the latest Core update should have corrected our peoblem?

image.thumb.png.4a4d91135017a93bc7fd6e2789cb33cf.png

 

Our problem is that SOME people aren't being picked up when we type in their names on a co-worker drop down list. 

For instance, we have a user called Taylor who doesn't get picked up by typing their name, but DOES get picked up if we use the Employee ID:

 

image.png.0aaaeee8c124a22b34ba6a89626acf02.png

 

image.png.15df2f829f433d6ebd0ca11375b159b6.png

 

I've tried lots of different names, but the only ones that I can't seem to work are people called Taylor for some reason!! 

So I was wondering if there is another fix coming which will help with this? 

 

thanks

 

 

 

 

Link to comment
Share on other sites

@Paul Alexander this stems from 

The incident for the issue reported there was closed as it was identified as a defect. The defect also has a fix in the latest Core update. However, there might have been some misunderstanding about the issue and the defect. What was fixed in the latest Core update was a subsequent or additional issue with searching in the standard "Co-Worker Search" form in PCF. The issue you (still) seem to experience is with the co-worker data query search in a custom form. While the standard "Co-Worker Search" and the co-worker data query search in a custom form share the same DB query they seem to behave rather differently... I can't work out exactly hows and whats, I'll ask the devs to help me with this one. Will keep you posted.

  • Thanks 1
Link to comment
Share on other sites

Alos, just to confirm, the "taylor" string does bring back (some) results, but there are (quite) a few results given that a) search is also performed on user email address and b) there are users in you system that have an email address that contain "taylor"... I think an easy test would be to temporary change the user last name from "taylor" to "tzaylor" (for example) and see how this new last name works when being searched for... I expect that to come up just fine...

Link to comment
Share on other sites

Hi @Victor

I assumed that was part of the problem....especially as it DOES only seem to be affecting taylors!

I did just change an account last name to Tzaylor, but that doesn't show up either? (if I do a search for Taylor OR Tzaylor, I still get no results...)

However, changing the name in the Handle field DOES then bring up the user.

Does that help?

Link to comment
Share on other sites

If the above sentence looks a bit odd in terms of wording and such then that mirrors my exact thoughts when I was investigating this issue... odd but sort of ok(ish), but not quite making sense...

Link to comment
Share on other sites

@Daniella R. Goral I cannot say this issue in the screenshot is actually related with the issue experienced by @Paul Alexander. It might be but given this functionality is a bit complex it might very well be something different. I would suggest raising as support request so we can investigate to confirm you are experiencing the same or is something different.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...