Jump to content

Human Task Timeline Update - no longer appears


Luke
 Share

Recommended Posts

We have seen a change in behaviour which I can't explain, we have a human task defined in a business process which used to create a timeline entry: 

image.thumb.png.52855236161799dfe587ac01105add04.png

This is no longer appearing when the same task is processed. The business process hasn't been published since October 2020 and I can't find any settings that can explain this change - the above example where the timeline WAS written to is from 29th April, today this is no loner working. 

A human task node just before this one is still creating a timeline entry: 

image.png.d3726516a8f539ac3b052106abdd9703.png

The 'Has the Date/Time changed?' node is writing to the timeline as expected, and the 'New Change Time Selection' node is not, this is the relevant part of the business process: 

image.png.73620d26da8124bd39b0ba3e5713d51c.png

The 'New Change Time Selection' node is using a single Outcome with 2 fields:

image.png.01797b627cd96bf62f6d46682d57054d.png

Fields: 

image.png.617dc4b2869c6bf8ba15a81ede4c3c62.png

And I've tried taking a copy of the business process and adding a new node to manually update the timeline, this is also not working, I've tried with visibility set to 'team' and 'public': 

image.png.13d8e2bc016bf6e94fc1dedfc9e73f61.png

Is anybody else having issues with timeline updates? Is this the result of a release? (we were updated to build 2223 19/05/2021 @ 01:01:40) 

Thanks, 

Luke

Link to comment
Share on other sites

Hi Luke,

Thanks for your post.  I'm not aware of any changes that would have affected this.  The update that you mentioned is a Service Manager application update, whereas the Human Tasks within the BPM are part of the platform which would be updated through different release.  I've not personally heard of other customers reporting this, but I'll keep my eyes open.  

In the mean time, you could try to first edit and save the Human Task node that isn't adding the timeline entry.   As the timeline entry is working for the other Human Task, it could be something specific to that node.   

Also, I see there is a decision node prior to the Human Task for changing the date.  It is also possible that something has changed in your environment and it is just taking a different path.  You should be able to look at the completed tasks on the ticket to make sure that this task was added and completed.  

Let us know how you get on.

James

Link to comment
Share on other sites

@Luke Found an issue with creating the timeline entry when a task with custom outputs are used.

You shouldnt need an extra node to create the timeline entry after the New Change Time Selected task is completed.

This will be fixed in the next Service Manager release in early June.

Link to comment
Share on other sites

  • 4 weeks later...
On 5/26/2021 at 8:46 AM, Victor said:

This has been confirmed as a defect. A fix for this will be included in next Service Manager app update (soon).

Now fixed in the latest release, tested and recording a timeline entry again. Thanks. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...