Jump to content

Azure User Import - .businessPhones


AndyHill
 Share

Recommended Posts

I noticed in the latest version of the Azure Import Tool we have switched from the following values. 

"Phone": "{{.telephoneNumber}}",

"Mobile": "{{.mobile}}",

to the newer values of

"Phone": "{{.businessPhones}}",

"Mobile": "{{.mobilePhone}}",

These both import the values i would expect but because businessPhones is an array it imports with the [] around the entry. Is there anyway to remove these brackets as it looks untidy?

Link to comment
Share on other sites

Hi @AndyHill,

Are you saying that telephoneNumber doesn't work for you anymore?

I'm not entirely sure how Azure works behind the scenes (I think it has switched about a bit - telephoneNumber should return the primary number indicated in businessPhones and mobilePhone, the mobile number indicated in there, but I know telephoneNumber doesn't return anything if it is not expressly set), but I have noticed that telephoneNumber doesn't work for everyone - and for those where it doesn't work, the businessPhones route is now given as an alternative.

You might also want to add businessPhones to the list of UserProperties.

Link to comment
Share on other sites

@SamS Hi Sam, yeah telephoneNumber is now no longer working. I switched it out for businessPhones which does work but because businessPhones is an array it puts the number inside [] which just looks a little untidy as where users haven't supplied a number they now just have [] showing.

image.png.93bc681e38abd2c05cdd1e51c0437c55.png

Link to comment
Share on other sites

  • 1 month later...

@SamS just been looking in to this again after reading the below:-

  • businessPhones is coming back as ["#phone#"] (a so-called "string collection"), so now stripping the phone number fields from any potential square bracket and double-quotes. Only "Phone" and "WorkPhone" (Profile) have been "treated" in this way. AzureConf.StringCollectionTweak needs to be set to true use.

I can confirm that when I use the WorkPhone setting under the ProfileMapping it does correctly remove the []. 

Problem here is I want the number mapping on to Phone under the AccountMapping section.

Link to comment
Share on other sites

Hi @AndyHill,

Are you trying to have two functionalities? i.e. removal of [] on WorkPhone and NO removal for Phone?

If so, then the best thing would be to run the import twice - one with WorkPhone configured WITH the tweak set (NO mapping on Phone),  and the other (without the tweak) mapping to Phone (but NOT on WorkPhone)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...