Jump to content

cant address custom field

Recommended Posts

hi guys - hopefully this is a quick one - i feel like im doing summit silly!  - i cant address a custom field in my process i dont think, or its not working as expected.

 so i have a task which has 2 questions, one is radioset field, one of these is a date control field, I have these mapped to customfield27 and customfield28. 




this matches what i see here when i try and reference the field later,




but does not seem to match the database field names,




can someone pelase confirm what i need to be naming the fieldID - to get the values stored properly?


(also ive tried doing this a different way, but i want to reference the value in a later stage, which it doesn't seem to let me do, it only shows me tasks within the current stage. however i can reference the ticket info and thusly the custom fields, so trying it this way.)

Link to comment
Share on other sites

edit, i actaualy use one of the fields later in the same stage to change the card title of the ticket - i reference this field using a get task answer, and this works,

LVRRQST - &[functions.getTaskAnswers("task-7ec2b8ec").Leaver] leaving: &[functions.getTaskAnswers("task-7ec2b8ec").customField27] - &[global["inputParams"]["requestId"]]


so im guessing just my field name is wrong and it not referencing the actual database field properly,



Link to comment
Share on other sites

hiya- sorry @Steve Giller - still not working for me, im addressing the field correctly i think, im trying to put a date field into a h_custom_b - which is a varchar field, and its not picking it up,

neither is h_custom_c  being picked up, which is a radioset field. 


for the date field i need to use the date picker i think (rather than the date/ time) as i reference this date later to drive a task (the task expires on this date), and im unsure if it will work with the a date / time value.



many thanks 





Link to comment
Share on other sites

  • 3 months later...

hey guys - did we get anywhere with this? im, trying to do another process ( i worked round the above i think by putting it all in the same stage, but this isnt ideal this time)


so im used a task with a capture task in my first stage,to capture a radioset value, which im trying to commit to h_custom_d, shown below





this is not populating the respective database field within h_itsm_requests though? h_custom_d is a varchar field - so should accept the value?




am i doing something wrong? i need to reference this value in a later stage, ive also looked at trying to reference the "task answers" in a later stage, but i cant work out how to reference a task from a different stage?




Link to comment
Share on other sites

@Gary@ADL Sorry, lost sight of this one.

I missed the word "Task" in the original post.
Custom Field mapping is only available in Progressive Capture from Customised Forms. To map Task answers to Request Custom Fields you will need to use the Update Request Details node to populate the required fields with the Task Answers.

Link to comment
Share on other sites

hi @Steve Giller thanks for this - sorry can you explain a bit more? ive added an update request node but it doesnt work still, 


with all the options i have in the update details node i have left then to ignore, because none of them look like they are applicable to what im trying to do? theirs no option to update task fields or custom fields etc from what i can see? so am i missing something?





Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...