Jump to content

Recommended Posts

https://wiki.hornbill.com/index.php?title=Service_Manager_Business_Process_Workflow#Request_Timers

Hi,

This forum was particularly helpful with another config change query I had, I was hoping to everyone's brains again?

Request Timers; we've recently looked to apply this new enhancement via Application Settings, we have looked to pause the timer on resolve, restart the timer on re-open or end timer on close. We've however found that calls that have been resolved, though they appear as paused seem to also show as 'Timer ongoing' and don't seem to end on close.

Our BPM's conditions for resolution timers are:

•    We do not mark the Resolve Timer as complete – it marks automatically when the call is resolved.

•    We have chosen to mark the response timer as complete when an analyst is assigned to the call. This is not the same as when the customer is contacted but does give us a measure of how quickly calls are picked up and assessed.

Via the Application Settings i understand that only one of either pause on resolve or stop on close can be enable.

Will we need to make changes to our BPM to be able to pause the timer on resolve and also have it continue if it gets reopened?

Regards
Rashid
MKC

Link to comment
Share on other sites

  • Victor changed the title to Resolution Timers - requires changes to BPM and settings?

Hi Rashid,

Thanks for your post. 

 

5 hours ago, Rashid.Ahmed said:

We've however found that calls that have been resolved, though they appear as paused seem to also show as 'Timer ongoing' and don't seem to end on close.

I believe that I may have replicated what you are experiencing with the display saying Timer ongoing after it has been closed.  I'll check with development to see if there is an issue there.

5 hours ago, Rashid.Ahmed said:

Will we need to make changes to our BPM to be able to pause the timer on resolve and also have it continue if it gets reopened?

You shouldn't have to make changes to your BPM if you are using these settings.  

image.png

  • Like 1
Link to comment
Share on other sites

Hi James,

Thank you for your quick reply

I think one of the settings that I didn't enable was app.request.stopresolutiontimeronclose setting 

I will try this tonight and will update yourself via this post on the result.

Do let me know if you get any info back from the Dev team, though this additional change to the setting may fix this issue i'm having (fingers crossed)

Regards

Rashid

Link to comment
Share on other sites

Hi James,

We gave this a go last night and unfortunately it still keep the resolution timer ticking even after the call is closed

Below is an image showing the settings we enabled (basically matching the image you provided earlier) , what the status of the resolution timer looked like at each stage of the call and finally the report (after the call was closed) confirming the fact that Hornbill still doesn't the resolution has been met.

Any advice on how we can get past this issue would be really appreciated

Regards

Rashid

image.thumb.png.dce905354e463fa4336467ab4d3ce608.png

Link to comment
Share on other sites

Hi @Rashid.Ahmed

Thanks for posting back, I've been having a look into this issue following James' comment and it looks like there may be an issue when using the settings rather than BPM to mark the resolve time on resolution.  I'm currently investigating and will post an update back here as soon as I have confirmed the issue and have a way forward.

Kind Regards,

Dave.

  • Like 1
Link to comment
Share on other sites

2 hours ago, David Hall said:

Hi @Rashid.Ahmed

Thanks for posting back, I've been having a look into this issue following James' comment and it looks like there may be an issue when using the settings rather than BPM to mark the resolve time on resolution.  I'm currently investigating and will post an update back here as soon as I have confirmed the issue and have a way forward.

Kind Regards,

Dave.

Thanks for investigating this David!

Regards

Rashid

Link to comment
Share on other sites

Hi @Rashid.Ahmed

Just an update, I've identified the issue which sadly does occur when just using the settings as you have configured.  I've implemented a fix for this and we'll get that included in the next Service Manager update (build > 2143).

Kind Regards,

Dave.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...