Jump to content

Unable to add basic users to groups


Recommended Posts

Hi,

It seems that I can no longer add basic users to groups. I am missing almost all tabs in the user admin area until I make them a user and then all tabs return and I can add them. 

I obviously dont want to have to add users if I dont need to. As soon as I set them back to basic it removes all groups from the user account. 

It also seems that some of the new default roles for docmanager portal dont work if added in LDAP import. And I cannot seem to set users home company from the admin page either. 

I have all required roles to manager users.

Link to post
Share on other sites

Hi Dan,

I believe that there has been a change where basic users can't be added to Teams, but you should be able to add them to any other Organisational Group.  I believe that the reason behind this change is that teams are used for operational purposes within all the of the apps which was creating a lot of issues when Basic users were added to teams.  Assigned tasks, notifications, assignments, etc are all based on team membership and Basic users could not access the related entities which caused a lot of errors and failed workflows.   

I believe that the docmanager portal role should be added to the Portal User account and not the individual Basic users. 

Link to post
Share on other sites

Hi @Dan Munns

The following release notes detail the recent changes to basic users. 

https://community.hornbill.com/topic/19101-new-update-hornbill-admin-tool-1285/
https://community.hornbill.com/topic/19194-new-update-hornbill-admin-tool-1288/
https://community.hornbill.com/topic/19280-new-update-hornbill-admin-tool-1292/

 

17 hours ago, Dan Munns said:

It also seems that some of the new default roles for docmanager portal dont work if added in LDAP import

Could you please provide details of the specific roles which do not work? 

 

17 hours ago, Dan Munns said:

And I cannot seem to set users home company from the admin page either. 


The Home Organisation can be set from the drop down list of organisations (company).  This list is filtered to show only the organisations the basic user is associated with. 

2509.JPG.dcaa3acb2b1f957bda052220ccc6a819.JPG

Link to post
Share on other sites

Hi @Mary

I assume that this change is the issue:

  • system - org structure - users: in basic user view do not allow user to be assigned to a org of type team.

Was there any reason for this? I only ask as I am now going to have to go through 4 pages of teams and change each one manually to 'General' or similar and hope that nothing else is impacted by this. (I am hoping that teams given access to CIs will not drop off the list and have to be readded)

The roles which fail to be added via LDAP are at least:

  • Docmanager Library User
  • Docmanager Portal

They show up as a blank box in the users roles and they cannot see the documentation they should be able to. There maybe more but I haven't tried/had any others reported to me. 

When setting Home Organisation, I can select the organisation from the drop down and then one of two things happens: 

  • I save it, all looks ok, I refresh and the field is blank again

or

  • I save it and get an error that there was nothing to change so I cannot save it. Field is still blank. Making another change to the user account results in the previous issue above.

Edit: Sorry just read @James Ainsworth post, (didn't see it until after I wrote this) anything which is covered by that can be ignored. But I dont get the 'portal user account' bit?

Thanks,

Dan

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...