Jump to content

Document Manager - Auto Tasks


Ade M
 Share

Recommended Posts

hi 

Im using  a doc manager auto task to move  docs from 1 library to a review Docs Library.   I get the following error 

Xmlmc method invocation failed for BPM invocation node 's1/flowcode-7bfdf24f': 0200 apps getDocumentInfo FlowCode Exception (com.hornbill.docmanager/entities/Document/fc_bpm/getDocumentInfo): Input parameter validation error: The element was expected at location ''

 

when i invoke a Get Document Information request. Can you point me in the right direction please

 

image.png.3a538148f286ba87383bb6e8f8068a87.png

 

 

Link to comment
Share on other sites

Hi

You need to create a input setting for the process called documentId, you can do this by clicking the Manage Process Button and clicking Add New in the Input Parameters and creating the setting documentId

image.png

You will then need to pass this setting into the get document info node by setting the Document Id option to &[global["inputParams"]["documentId"]]

image.pngWhen you create you custom button you can then pass the documentId through to the autotask by entering [[documentId]] in the documentId field

image.png

Thanks

Trevor Harris

 

Link to comment
Share on other sites

  • 2 months later...

Hi @TrevorHarris  It was really useful to find this post.  I thought it would solve my very similar issue but I get a slightly different error 

 

Xmlmc method invocation failed for BPM invocation node 's1/flowcode-76eebbc5': 0200 apps publishToLibrary FlowCode Exception (com.hornbill.docmanager/entities/Document/fc_bpm/publishToLibrary): Input parameter validation error: The element was not expected at location '/methodCall/params/library'

I have added the settings you suggested in your response but still get an error.

Thanks 

Helen

 

Link to comment
Share on other sites

Hi

I suspect this would be the same problem, that the documentId is not being passed from the custom button into the autotask node correctly, can you check the custom button auto task config make sure you've set the documentId param to [[documentId]] and also check that in the publish to library node the Document Id option is set to the correct input param (by using the variable picker)

Thanks

Trevor

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...