Jump to content

Tickets "From" template wrong


John C
 Share

Recommended Posts

@ArmandoDM

I just changed the settings (above) and I couldn't get an assignment email to be sent, so I reverted back to the defaults (as they were before I made the change) and now I don't seem to be getting ANY assignment emails (team or analyst assignments). This is how they are now and it doesn't look like it's working....

image.png.387f6754b7a1dd3f55441f2835b9e498.png

image.png

Link to comment
Share on other sites

Guest Ehsan

@John C Previously, some of the Service Manager notifications (e.g. guest.app.requests.notification.notificationType.assignment setting) were sent from a mailbox and some others were sent from a noreply address (e.g. guest.app.requests.notification.notificationType.portalUpdate setting). In the last build, we unified this approach but as evident here, this unified approach is not desired and we'll have this reinstated. Please bear with us and we'll have this reinstated as soon as possible.

Link to comment
Share on other sites

@all

Apologies I am not fully online on forums right now (as indicated by my username). However I was made aware of this forum post. Until the previous functionality is reinstated (as mentioned by Ehsan), to have notifications working in your system please amend the following SM app settings: guest.app.requests.notification.emailPrefix and guest.app.requests.notification.emailDomain to mimic your mailbox address.

For example, if your mailbox address is IT_Support@companydomain.co.uk then set up the setting as:

guest.app.requests.notification.emailPrefix = IT_Support

guest.app.requests.notification.emailDomain = companydomain.co.uk

guest.app.requests.notification.emailDomain = companydomain.co.uk needs to be a valid outbound route in Home - System - Email - Outbound Mail Routing

Link to comment
Share on other sites

Guest Ehsan

@John C meanwhile I would suggest if you could please update your settings as per @Victor (Offline) 's instructions. We'll reinstate the behaviour as previously mentioned but as a Hornbill best practise, we would recommend that you update those settings for any emails that are not sent directly from a mailbox.

Link to comment
Share on other sites

Guest Ehsan

@John C Sorry this may be a misunderstanding but "IT Service Desk" is not a valid email address as it has spaces in it. "IT Service Desk" appears to be a display name rather?

In the example below, I've set a gmail account as my shared mailbox. In the Default Address field, the value before "@gmail.com" would be  the value to update guest.app.requests.notification.emailPrefix setting with. For example if the default address were "ehsan_development@gmail.com", the emailPrefix would be "ehsan_development". 

image.png

 

Link to comment
Share on other sites

@Ehsan yes display name, see mails from yesterday as IT Service Desk, and today they show as noreply...

If I change the noreply option you speak of, to IT Service Desk, we receive no emails at all.........

 

image.thumb.png.9a0a74e2c1b5d8f8c54c6135cf7b8610.png

 

image.thumb.png.030870d329202bbaddc9a3ee322f0015.png

Link to comment
Share on other sites

@John C don't update the email prefix (guest.app.requests.notification.emailPrefix) to "IT Service Desk" ... IT Service Desk is the display name of your mailbox and the display name for the mailbox address in your email client. Email prefix is what the name says, the prefix for the resulted originating email address. As I said in my example above and mentioned by Ehsan too, have a look at what is the email address for your mailbox (not the mailbox display name, the actual email address). Then for guest.app.requests.notification.emailPrefix put whatever value you have before @.

So your email display name is "IT Service Desk" (which might also be the mailbox name in HB) but the actual address can be "support_desk@yourcompany.co.uk". In this case the value for the email prefix app setting is "support_desk" and not "IT Service Desk"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...