Jump to content

Unable to amend a customers Site details


Adrian Simpkins
 Share

Recommended Posts

Hi All

So we have accounts loading from 3 different Sites, and each Site has its own name set during the LDAP upload (Basildon,  Mid and Southend). This data is then used in the Details tab and in custom request list views to filter by Site for our teams.

However, I note that on most accounts I can change this Site in the Details tab which allows us to move requests to a different Site queue if required (we have staff working across all 3 sites so someones Computer logon shows as Site A, but they are working at Site B so our team filter by main site to identify the bulk of their work).

But we have one account where I am unable to change the Site field, it just keeps defaulting to the value set as part of the LDAP upload. I have compared their account against other customers, and can see no obvious reason why. I am able to change their Site direct in the Organisational Data / Users, but when I look at the request this customer has raised I am unable to amend it from their AD loaded Site here?

Anyone know why this may be happening at all please?

Thanks !

Link to comment
Share on other sites

Hi Adrian,

I believe that the normal behavior is that you can only change sites to the ones that are associated to that user.  It may be that for some reason that user is only associated to one of the sites. 

There is this setting that does away with any checks for the sites where the customer is linked.  It just lets you select any site that you defined in your organisational date.  Let us know if you think that this may help.

image.png

Link to comment
Share on other sites

  • 2 weeks later...

@Adrian Simpkins

Just an update on this one: 

Turn on this app setting and you should have access to all available sites in your system when editing request details: app.request.update.site.showAllSites. If this setting is turned OFF then the list of available sites for selection is filtered based on customer associated site. Turn it ON and all sites are available for selection.

Many thanks, Nanette.

  • Like 1
Link to comment
Share on other sites

  • 10 months later...

Hi All,

So I have another request where we are unable to change the Site on the Details tab - I have double checked and app.request.update.site.showAllSites is still set to On - however, I am unable to change the site to one of the others (we have 3 main sites we set our requests against to filter to different site teams). I can change the Site with no issues on other requests but have this one request where no one can change the Site?

Also the User who raised this issue mentioned the ability to change the Site appears sporadic - one week she could change it, then next she was unable to change it.

I have also tried it on 3 browsers:

IE - IE is not populating the Site when I change it in the details tab at all so unable to change the site at all

Edge - Edge shows the alternative Sites when I start typing, but the Save button is not available to confirm change

Chrome - same as Edge - shows the Sites, but no option to Save on the details tab.

Any ideas why one specific request will not let us change the Site please?

Many thanks as always

image.png.8ebecf1a26b067e4313b50485de7fa81.png

Link to comment
Share on other sites

Hi Victor,

The issue is changing the Site on a Request in the Details tab once it is assigned to a User. We have 3 main sites that load as part of our OU / LDAP import so each customer is set to one of the predefined 3 sites. Our teams then use the Site filter to set their work, and sometimes the Site the Customer has set needs to be amended so that the team(s) on the other Site can then view it in their Request List. 

The issue is that on this particular request we need to change the Site but when I go to change it the Save option at the bottom of the Details tab is 'greyed' out so only the Site the Customer has set against their profile is available. However, when I try this on other random requests I have no issue in changing this Site field in the Details tab, so just trying to understand why unable to change it on this particular request.

I have just double checked the setting app.request.update.site.showAllSites and this is still set to On as per last updates

Hope that makes sense :)
 

Thanks

 

Link to comment
Share on other sites

Hi Victor,

Just tried it again on all 3 browsers today:

IE: doesnt load any Site other than the one that is loaded from Customers Profile

Edge: Appears to let me change the Site?

Chrome: Appears to let me change the Site?

It definitely was not working yesterday for myself, or the User who raised the issue, however when trying it today it appears to be working now? Not sure why it was not working before today on this specific request though still? I have just tried it on a handful of other Requests and all appear to let me change the Site with no issues.

So it looks like the Support Ticket can be closed, I will keep an eye out for this occurring again, and if it does I will repost / raise another ticket> I will talk to the Users who highlighted it to check they can do this now as well

 

Many thanks !

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...