Jump to content

Failed to update Failed BPM


Paul Alexander
 Share

Recommended Posts

I've just tried to look at a 'failed' BPM and attempted to change something to see if I could get it working and it's gone a little....er...awry!! 

 

Here's how the BPM looked originally (in it's failed state....which is fine, the BPM error says that it can't find an owner and that's because I've forgotten to add a 'get request details' node)

 

image.thumb.png.c579b352eb887185ba9543535bf0dbb1.png

 

 

 

So, I made a change (in this instance I just thought I'd put a decision in to bypass the 'Value Added' activity, just to get me out of this particular mess...as I know the team didn't want to bother with this particular activity.

image.thumb.png.3ea99f15baea13e4c0218c4957afd1cd.png

 

 

But, when I went to save the stage, I was told that there were items which weren't set up correctly, so I refreshed the page and this is what I'm left with.....which is a complete mess, and has completely different stage checkpoints and parallel processes in a completely different order! I now can't get back to the original BPM to save it. 

image.thumb.png.d0c790554b86e7fae2bdb556c1aa7072.png

 

I thought maybe this was a one-off glitch, so I tried it on another failed BPM (of the same type:INCIDENT - V-FORMS-Default Incident (Version 2)) and exactly the same thing happened. I've done this quite a few times before and I haven't had any problems with updating failed BPM's, so any idea what's happening please?! 

 

 

 

 

 

Link to comment
Share on other sites

Hi Paul,

In theory, you shouldn't be able add a new node to an existing BPM Instance.  You should only be able to change the options with the existing nodes.  I'm guessing you used the Replace Node option?  If that is the case, have you tried putting it back to the original node type?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...