Jump to content
samwoo

Issues with clicking a URL to a page on the Self Service Portal

Recommended Posts

Hello,

One our of Project Managers has discovered an issue where if he puts the URL into a Word or Excel document which is a link straight to a Service on the Self Service Portal (ie. https://service.hornbill.com/<instances>/servicemanager/service/38/), and the Portal is set up to use Single Sign-On, it takes us back to the list of Services after Single Sign-On.

Quite a few of us tested this (some on Office 2016, others on Office 365) and the same thing occurs.

I did some reading up on this, and it is already a known limitation with the Office Products:
https://support.microsoft.com/en-gb/help/899927/you-are-redirected-to-a-logon-page-or-an-error-page-or-you-are-prompte
https://developer.ibm.com/answers/questions/204906/why-does-clicking-on-a-hyperlink-from-micrsosoft-o/

I then tested this with a direct link to a SharePoint page sub page (which is our Intranet), and it worked fine.  Curious, I asked someone else to test another Application that uses Single Sign-On via a link in an Office document and the same issue occurs.

I was wondering if this is something that is already known at Hornbill, and if there is a way for this to be fixed?  There are some workarounds presented on the Website above, but if SharePoint works then I wonder if it's because Single Sign-On redirects to the first main page, rather than the requested page and whether this is something that can be looked at in the future?

Replication steps:

  1. Log on to the Self Service Portal as normal
  2. Navigate to a Service to see the Catalogs
  3. Copy the URL to that Service
  4. Paste that URL straight into a Word or Excel document (we could only test with Office 2016 and above)
  5. Open the URL from the document, you can see it navigates to the Single Sign-On page and takes you straight to the List of Services instead.

Thanks,

Samuel

Share this post


Link to post
Share on other sites

this works as expected for me... link to https://service.hornbill.com/<instance>/servicemanager/service/9/catalogs/ in a Word document and ctrl+click takes me to that catalog.... I'm using Office 365 ProPlus build 1902.

I can see the adfs redirect kick in and then it opens on the the correct service landing page ...

A link to the catalog item directly works as expected as well -> https://service.hornbill.com/<instance>/servicemanager/log/9/serviceRequest/33/

Share this post


Link to post
Share on other sites
4 hours ago, SimonSheldon said:

this works as expected for me... link to https://service.hornbill.com/<instance>/servicemanager/service/9/catalogs/ in a Word document and ctrl+click takes me to that catalog.... I'm using Office 365 ProPlus build 1902.

I can see the adfs redirect kick in and then it opens on the the correct service landing page ...

A link to the catalog item directly works as expected as well -> https://service.hornbill.com/<instance>/servicemanager/log/9/serviceRequest/33/

Hi @SimonSheldon,

Thanks for this -  It was interesting to look online to find that it's known limitation... but, it doesn't appear to be affecting yourself.  I am on Office 365 (the latest version... it auto-updates and I have to restart Office 365 when this happens) and I've got the issue above.

Is it likely to be from the ADFS setup on our end that's causing this?

Thanks,

Samuel

Share this post


Link to post
Share on other sites

I didn't set up our ADFS (and have limited knowledge of how it works) so not sure on that @samwoo but might be worth a look if there's some sort of setting that handles what it redirects back to after auth?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...