Jump to content

Guest Account (Contacts) Portal Password Setting


Recommended Posts

Hi,

We are in the final few days now before we are going to go live with an external customer facing Customer Support Portal for in excess of 350 contacts.

Is there a script that can assign a predefined 'initial' password to every Guest Account for the Customer Portal, so the contacts can at least log-in and get to the profile section to change their password to one of their choosing?

Alternatively, if there is no script, if we choose 'set Random Password', does this get communicated to the Guest Users (Contacts), so we do not need to know their passwords?  Better security practice.

Thanks in advance.

Steve.

Link to comment
Share on other sites

1 hour ago, Martyn Houghton said:

@Steven Cotterell

There is a setting under Portal Accounts in the Admin tool which allows you to control whether users are allowed to change their own passwords, so would be worth checking that first.

image.png.7133c03a32aecddc51e0e79adcbc9263.png

image.png.afe39202dc35294eafcb6dbbd69296ff.png

Cheers

Martyn

Thanks @Martyn Houghton.  

I saw that earlier and checked the box in the 'Customer' portal config.  With this box ticked, I now get...

 image.png.356ce7ad644460e662f662b821411aa3.png

Any other ideas please??

Link to comment
Share on other sites

@Steven Cotterell

That sounds like there is something not quire correct in the email configuration or permissions on your instance. I suspect you are going to need your Hornbill switch on consultant to look at this.

In terms of your original general queries, though.


Is there a script that can assign a predefined 'initial' password to every Guest Account for the Customer Portal, so the contacts can at least log-in and get to the profile section to change their password to one of their choosing?

When we did our original migration quite a few years ago, Hornbill as part of the switch on were able to migrate our existing customer contacts with their password, as there where several thousands of them, so it depends how you populated them really.

Alternatively, if there is no script, if we choose 'set Random Password', does this get communicated to the Guest Users (Contacts), so we do not need to know their passwords?  Better security practice.

As you have discovered, the way we have done subsequent migrations of additional desks into our instance, is to use the Forgot Password option. We provide the customer with a brief user guide and provide them with the steps to use the Forgot Password option. 

 

Hopefully you can get the email issue sorted so you can use the latter option. One thing to note, I would recommend that you update your "security.guest.xxxxxxx" setting in the System>Settings>Advanced section in the Admin Tool to match your security policy before going live, so that they are applied to all your new external contacts, as there is no way currently to expire customer password and force them to reset them using the updated security setting.

Cheers

Martyn

Link to comment
Share on other sites

I sat and pondered and stared hard at the error message and I have managed to fix what was happening.  The Forgotten Password' functionality now works.

I had earlier (a few weeks ago now) removed 'live.hornbill.com' from the outbound mail routing as I just wanted our outbound emails displaying our domain.  

image.thumb.png.061ec736eefb5c33af2af38de94d8a9b.png

I hope that by adding this in, alongside our domain, doesn't cause outgoing emails to display a 'hornbill' address.

Onwards & upwards!! :D

 

 

Link to comment
Share on other sites

@Steven Cotterell

We used to have the same in our shared mailboxes but we got clarification that it was not needed in our case, as it was taking up a mailbox licenses, and out forgotten password emails still come from live.hornbill.com, but at least you got it working.

In terms of default mailbox, there is a setting on each service which sets the default mailbox, but as long as your users only have permissions to your primary mailbox then there should not be an issue. The default mailbox setting is more for when you have users with permissions to multiple mailboxes.

Cheers

Martyn

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...