Jump to content

BPM Stuck - Unable to select authorisers


Dan Munns
 Share

Recommended Posts

Hi all, 

I have a BPM which is stuck at 'Suspend - wait for list of request authorisers' but the key isn't displayed to enable the analyst to select the authorisers. 

This BPM has worked fine for the last 2 months. Action focus is set to Authorisers as well. 

This is fairly urgent so if someone could have a look ASAP it would be appreciated. 

Thanks

Dan

@Victor (tagged so someone see it)

Link to comment
Share on other sites

@Victor the option has just miraculously appeared (didn't even refresh the page again)

I did notice a fair few of these though:

753794	02/04/2019 11:05	warn	comms	8036	Operation[bpm:processResume] The specified bpmProcess cannot be resumed: The process (BPM20190326000083) is currently busy with: taskResume
753510	02/04/2019 11:05	warn	comms	13748	Operation[bpm:processResume] The specified bpmProcess cannot be resumed: The process (BPM20190326000083) is currently busy with: taskResume
752429	02/04/2019 11:05	warn	comms	3508	Operation[bpm:processResume] The business process instance cannot be resumed (Process:Execute: could not find suspended flowcode node to resume)

The BPM process ID matches.

Link to comment
Share on other sites

@Victor from the last task being completed (Select Authorisers) to the suspend node generating the key took 32 minutes. The entire time the BPM live instance viewer showed as below.

The select authorisers task provides a drop down list to allow selection of up to two users and then updates 2 custom fields (in the update request details node directly after) to be used as variables in the two standard authorisation nodes.

This has always worked fine up to today. 

I have also had a number of people complain about performance issues over the last few weeks (pages taking a while to load and displaying the spinning circle for a while etc.) Cache cleared on all affected machines but they are saying it is still an issue.

image.thumb.png.2bcd654932c68b450a8b3ff534dd1e78.png

Link to comment
Share on other sites

@Dan Munns - I don't think it actually took 32 min... I was just thinking maybe it took a bit longer but not that much... maybe it was a refresh issue? If it happens again, raise a support request so we can investigate in more detail... Regarding the overall slower performance, I am not aware of any issues affecting your instance. If this is persistent, again, we can look over this in a support request...

Link to comment
Share on other sites

@Victor well from the last task being completed to the key turning up to the party, through multiple F5 / Ctrl F5s / browser restarts / clearing caches it took 32 mins.

And it appeared on for all users at roughly the same time no matter what actions from the list had been taken. 

I will keep an eye on it and raise an IN ticket if it happens again. 

Thanks (as usual) :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...