Jump to content

SMTP SmartHost help


David Longley
 Share

Recommended Posts

We are looking at setting up email to be sent from our domain. We are using the SMTP Smarthost solution.

we are using the below settings:

 

image.thumb.png.f531009a81d1b0d05da7c30ce3cdc10e.png

and when we click on test, we get the below. The port does say 587... but for some reason not showing on the above image,

Unable to send test message to the specified recipient

ChilkatLog: SendEmail: DllDate: May 25 2017 ChilkatVersion: 9.5.0.68 UnlockPrefix: QHRNBLMAILQ Architecture: Little Endian; 64-bit Language: Visual C++ 2015 / x64 VerboseLogging: 0 sendEmailInner: renderToMime: createEmailForSending: Auto-generating Message-ID --createEmailForSending renderToMime: Elapsed time: 0 millisec --renderToMime sendMimeInner: ensureSmtpSession: ensureSmtpConnection: SmtpHost: smtp.office365.com SmtpPort: 587 SmtpUsername: test@limoss.london SmtpSsl: 0 StartTLS: 0 smtpConnect: smtpHostname: smtp.office365.com smtpPort: 587 connectionIsReady: Using existing/open SMTP connection to send email. --connectionIsReady ConnectionType: SSL/TLS --smtpConnect --ensureSmtpConnection --ensureSmtpSession sendSmtpEmail: sendWithPipelining: sendMailFrom: mailFrom: do-not-reply@live.hornbill.com sendCmdToSmtp: SmtpCmdSent: MAIL FROM:<do-not-reply@live.hornbill.com><CRLF> --sendCmdToSmtp --sendMailFrom sendRcptTo: sendCmdToSmtp: SmtpCmdSent: RCPT TO:<david.longley@limoss.london><CRLF> --sendCmdToSmtp --sendRcptTo sendCmdToSmtp: SmtpCmdSent: DATA<CRLF> --sendCmdToSmtp readSmtpResponse: SmtpCmdResp: 250 2.1.0 Sender OK --readSmtpResponse readRcptTo: readSmtpResponse: SmtpCmdResp: 250 2.1.5 Recipient OK --readSmtpResponse recipient: david.longley@limoss.london --readRcptTo readSmtpResponse: SmtpCmdResp: 354 Start mail input; end with <CRLF>.<CRLF> --readSmtpResponse --sendWithPipelining mimeDataSize: 439 sendDataToSmtp: numBytesSent: 439 --sendDataToSmtp sendCmdToSmtp: SmtpCmdSent: <CRLF>.<CRLF> --sendCmdToSmtp readSmtpResponse: SmtpCmdResp: 554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 16.55847:AF100000, 17.43559:0000000094000000000000000100000000000000, 20.52176:140F6B86000010100A00C431, 20.50032:140F6B86821710100A00DD31, 0.35180:5D3F0000, 255.23226:0A00D431, 255.27962:0A000000, 255.27962:0E000000, 255.31418:1F000130, 16.55847:AA000000, 17.43559:0000000070010000000000000200000000000000, 20.52176:140F6B860000101003000136, 20.50032:140F6B86821710100A00DA36, 0.35180:4C000000, 255.23226:4800D13D, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:0A003A66, 4.21921:DC040000, 255.27962:FA000000, 255.1494:6C000000, 0.38698:0F010480, 0.37692:0F010480, 0.37948:00000000, 5.33852:00000000534D5450002E3136, 4.56248:DC040000, 7.40748:010000000000010B01022E4F, 7.57132:00000000000000003A306166, 1.63016:32000000, 4.39640:DC040000, 8.45434:FD38F2FDAB5F4F498FCC8162A1BE780A3A306166, 5.10786:0000000031352E32302E313634332E3030303A4C4F32503236354D42303836333A30616666646437322D303064332D343236372D393730632D3566393661393936653839360040101A010480, 255.1750:A8000000, 255.31418:0A005636, 0.22753:AD000000, 255.21817:DC040000, 4.60547:DC040000, 0.21966:03003866, 4.30158:DC040000 [Hostname=LO2P265MB0863.GBRP265.PROD.OUTLOOK.COM] --readSmtpResponse Non-success DATA terminator response. --sendSmtpEmail --sendMimeInner --sendEmailInner Failed. --SendEmail --ChilkatLog

image.png

Link to comment
Share on other sites

I'm not sure about the display of the port, but something maybe worth looking into regarding the error message is that I have in the past tried to set up email to work with a server that requires 2 tier authentication.  To get around this, some mail servers have an option to register or allow 3rd Party solutions to authenticate without the 2 tier authentication.  My particular setup was with gmail.  I'm not sure if Outlook.com offers the same, but I thought it was worth mentioning just in case.

Regards,

James

Link to comment
Share on other sites

Thanks for the reply James. We currently only use 0365 for mail (no physical exchange servers) with MFA enabled. If i disabled MFA and use that account to test my connection, i get the same error.

I do have an email connector setup in 0365 as well as per the recommendations but still no joy. 

My inbound mail setting on my shared mailbox is using the pop3 service on port 995

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...