Jump to content

Postman returning API Page?

Recommended Posts

Hi Guys,

Have been trying to pull from the API, I have created a key and tried running GET /session/?op=getSessionInfo to api.hornbill.com but all it seems to return is the API help page?

I've been doing this postman, and i'm sending the API key in the header like Authorization: ESP-API <apikey>

Probably doing something wrong :)


Link to comment
Share on other sites

Hi @RyanMesser,

You'd get a 501 returned if the request type was set to something other than GET or POST as those are the only methods enabled on the web servers. I've tried a POST to that service for your instance and I get a status of 200 back as expected -  with an error in the body telling me that the API key is incorrect :) 

Can you add this request to its own Postman collection, then share it and send me the link in a private message please? If so, then I can import it into my Postman and see what's going wrong.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...