Jump to content

Reports schedule - not working


Gemma Morrison
 Share

Recommended Posts

Hello,

I have created quite a few reports to run monthly and for the past two months, they have not done so. So I have been going in manually updating each document that they have been linked too.

Would someone be able to advise me if I need to add anything in? I am struggling to find the issue!!

( I have changed the next event date to next month, but want to see if I have missed anything beforehand)

2051018878_2018-11-0611_27_36-Administration_Facilities-FaultReporting-NumberofFaultsResolved(Last.png.cdebe0b47495c9f911a7854a67e6990c.png

 

1533391121_2018-11-0611_27_05-Administration_Facilities-FaultReporting-NumberofFaultsResolved(Last.png.d004342ebfe6e035c5b01849ec05ea1b.png

Link to comment
Share on other sites

@Gemma Morrison ok, found the issue...is all to do with when the scheduler was created and for what day of the month... and hour... You most likely created this when BST was in play ... So, 01/03 00:00 BST is 28 (or 29)/02 23:00 GMT (because BST = GMT+1). And this is where the error occurs, it tries to go back an hour form 01/03 00:00 and it fails to retrieve a valid day for end of Feb...

Anyway, easy fix, just reschedule all reports with this configuration (1st day of the month at 00:00) to run at 01:00 instead... or 02:00 ...

Link to comment
Share on other sites

  • Victor changed the title to Reports schedule - not working

Victor,

We checked this - the schedule was initially set for the 1st of each month to run at midnight however these had all changed to 11pm on the 31st. This, I think, may have caused it to fail as some months do not have a 31st and therefore there was no data to run off.

Will this continually be an issue each time the clock change? cc: @lokent

Link to comment
Share on other sites

Just now, Gemma Morrison said:

the schedule was initially set for the 1st of each month to run at midnight however these had all changed to 11pm on the 31st. This, I think, may have caused it to fail as some months do not have a 31st and therefore there was no data to run off.

The system knows what day to select if it goes back 1 hour from 1st of the month at midnight... It seems to have an issue with Feb though because some Febs end with 28 others with 29...

If you set it to run at 1 AM or 2 AM, you won't have any issues going forward...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...