Jump to content

Error - There is a CSRF token mismatch, request cannot be process: mailadmin

Aaron Summers

Recommended Posts


Can someone help me to fix this issue urgently. It having a huge impact with my work and unable to carry out my projects. I am not sure what caused this and I have tried few steps:

Hard refresh
Restart computer
Shut down
Clear cookies

None fix the issue. I have screenshot from console of the error if that help to identify the issue(s):


Can someone get back to me ASAP to get this fix please.

Kind regards,
Aaron Summers :) 

Link to comment
Share on other sites

@Aaron Summers clearing cookies should fix the issue, but you've already tried that :)

Do you have multiple tabs open, might be worth trying one tab at a time and let us know if it works OK then? I've let the relevant teams know about this issue so if we find anything someone we'll report back.

Link to comment
Share on other sites


Apologises for the late reply, I was away for the weekend to France.

I did have multiples tabs opened but never have a problem before this: (P.S I did tried to have one tab at the time, that did not work either).

I came back today and it seems to be fixed now.

Aaron :)

Link to comment
Share on other sites

  • 1 month later...

Hello @Chaz

I just a thought to let you know that the issue had reappeared and almost at every page - it kept saying "you have been disconnected..."


Often the error would show "invalid session..."

I have already tried all the steps as before as well have it own tab with Hornbill only but nothing works so far.

Aaron :ph34r:

Link to comment
Share on other sites

Hi, @Aaron Summers

Sorry for the problems you're having, I've discovered a possible cause for this problem can occur if a window or tab is left open for a long period of time but no longer used.  We are currently working on addressing this, if you are having this problem currently I would recommend closing ALL browser windows and tabs and completely restarting the browser to ensure that this is not caused by a stale window or tab being left open.

Sorry for the inconvenience

Trevor Harris

  • Thanks 1
Link to comment
Share on other sites

  • 5 years later...

@TrevorHarris Hi is there an update on this issue please?

We have several users who are experiencing this issue and getting errors like the above.  Here is an example:


It is happening in both Chrome and Microsoft Edge.

I have asked them to clear the third party cookies from their browsers and awaiting updates as to whether this has helped.

Is this specific to Hornbill or is it a browser issue?

Is there anything else that we can try?


Link to comment
Share on other sites

@TrevorHarris thanks.  One of my colleagues is getting this error when trying to update/edit Assets and when they refresh the browser the editing/updates are lost.  I am investigating how they are working, however it is disrupting their work so I would appreciate any other suggestions as it would seem to still be an issue.



Link to comment
Share on other sites

  • 4 weeks later...

@TrevorHarris We still have a few users who are seeing the CSRF Token error intermittently when working in Hornbill.

We have cleared cookies and the users are trying to use fresh tabs in their browsers but it still occurs.

Can this be looked at again please?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...