Jump to content

BPM node set status does not allow on hold


HHH
 Share

Recommended Posts

Hi

When creating a new BPM I use the Automated ATsk node to set status and sub status for a certain type of ticket. However the node does not allow me to set status to "on hold"

When I set the sub status (which is an on hold) substatus and leave the status field to Auto, the BPM crashes.

 

Statuses.jpg

Link to comment
Share on other sites

@HHH in the place on hold option it does require either the On Hold Period or the On Hold Until fields to carry a value / variable - in these cases it then functions as expected.

If you don't want to put this on hold for a time / period then using the update status option is the correct one.

I have just tested the update status option and have the On Hold option available and also selected a sub status

image.png

This correctly put my request on hold for an undefined period.

image.png

Are you on the latest build of service manager?

Steve

 

Link to comment
Share on other sites

@HHH - most likely reason why you don't see the "On Hold" status in the list when configuring the node is that the simple list, used to populate the values there, does not have this value... Please have a look at the simple list to see if the value is there and if not add it. Then try again in the node configuration.

image.png

 

P.S. - The "correct" way to do this would be to use the "Place On Hold" dedicated node as the list had the value removed for this reason. You can add it in the interim to have your node working but is a temporary solution.

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...