Jump to content

Recommended Posts

Hi,

We are currently importing various types of assets into our Service Manager instance.

We have found that, when logging an incident/service request via the customer portal, all types of assets are presented to the customer - including servers, switches etc. We would like to be able to filter out certain asset types on the portal, via the "asset details" out of the box form, so that only those relevant to the end user are presented.

Is there any way that this can be achieved? I've looked within the "Asset Management" section of Service Manager and cannot see anywhere that this would be set.

Thanks

Lauren

Link to post
Share on other sites

While we look into this, I was sure that when the Asset form is presented to a customer on the portal, that it only shows the ''My Assets'' tab and not the all assets.  My Assets being assets where the customer is set against the asset in the Used By field.  I could be wrong.  Out of curiosity, @Lauren when running through the progressive capture on the portal, are you doing in the context of a end user or are you doing this while logged in as a user that has rights and uses Service Manager?

You may have seen that some of the Progressive Capture forms now have Options, for example the Assign form has an option to make the owner mandatory or the ability to provide a description on the Attachment form.  These options will continue to be added to the different progressive capture forms.  In the case of the Asset Progressive Capture form we will look to provide options for setting which tab is available or possibly some other types of filters and maybe a description so you can provide instruction about the type of asset that you want them to attach.

Regards,

James

Link to post
Share on other sites
  • 2 weeks later...

Hi @James Ainsworth

I have found this morning that within progressive captures, we can filter asset types using custom forms. Using Data Provider "Get Assets by Type", we can enter the type we wish to appear in the "Type" field. There are two questions I have with this - 1) is there a way to actually link the asset automatically to the request once it has been logged, based on what has been selected from that list? 2) is there a way to filter on multiple asset types? I've tried adding commas/semi-colons between the different asset types but this doesn't appear to work.

Thanks

Lauren

Link to post
Share on other sites

Hi @Lauren

1) The asset can't currently be linked automatically.  We do have this planned as a second phase to the recently released feature for the assets on the Data Provider.  I'm looking at providing some new BPM operations for managing assets on requests. 

2) At the moment You can also only filter on one asset type.

Regards,

James

Link to post
Share on other sites

The current functionality provides the following.  

image.png

We will continue to look into options to expand this.  At the moment, as mentioned above, the Get Assets by Type only allows for one Type to be entered. 

Regards,

James

Link to post
Share on other sites
  • 9 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...