Jump to content

Data Query doesn't fire Override Flags


Aaron Summers
 Share

Recommended Posts

We currently have some options in a PC where if a user chooses an option based on a Data Query, it should fire an Override flag if it meets the criteria for another question to pop up.

I think this may relate to @samwoo's other query where the Data Query is actually returning the ID instead of the Value, which if this is the case is causing issues. 

Can you confirm that this is the case? We need the Override flag to look at the Value of the Data Query selected, not the ID. This is getting a bit urgent as we've had to show all fields which should only show based on different selections as a workaround and thus cluttering the PC forms.

Thanks

Aaron :) 

Link to comment
Share on other sites

@Aaron Summers @samwoo I created simple pro cap flow where I put custom form with site selector, then I added two hidden labels with conditions. Labels become visible if you pickup specific organisation (matching id). Also added branch and depend on selected organisation is going to specific form. All works as expected. Can you have a look and say if this is the case or its different problem?
Here you have a short video how it works https://www.screencast.com/t/k7iL64S0

Thanks, 
Miro

Link to comment
Share on other sites

1 hour ago, Miro said:

@Aaron Summers @samwoo I created simple pro cap flow where I put custom form with site selector, then I added two hidden labels with conditions. Labels become visible if you pickup specific organisation (matching id). Also added branch and depend on selected organisation is going to specific form. All works as expected. Can you have a look and say if this is the case or its different problem?
Here you have a short video how it works https://www.screencast.com/t/k7iL64S0

Thanks, 
Miro

Hi @Miro,

We were hoping to not have to use the ID at all, for example for the Site Data Query, we have set up Sites titled "Other" for example Other (Organisation 1) Site, Other (Oganisation 2) Site etc. We just want to look at the name of the Site and trip an override flag if it "Contains" the word "Other" for example.

If we can find a way to not use the "ID" but the name of the "Record" in the Data Query then it would be far better and easier to work with in the BPM.

Thanks,

Samuel

Link to comment
Share on other sites

Hi @samwoo 

In theory it could be possible by adding another site definition that return site name instead of id but in practice it would fail if there would be two or more same names or someone will change name later. Also adding almost redundant query definitions for this is not the best idea.
Anyway we are aware of this problem and looking for a proper solution and hopefully have one soon.

Thanks,
Miro

Link to comment
Share on other sites

On ‎9‎/‎13‎/‎2018 at 10:18 AM, Miro said:

@Aaron Summers @samwoo I created simple pro cap flow where I put custom form with site selector, then I added two hidden labels with conditions. Labels become visible if you pickup specific organisation (matching id). Also added branch and depend on selected organisation is going to specific form. All works as expected. Can you have a look and say if this is the case or its different problem?
Here you have a short video how it works https://www.screencast.com/t/k7iL64S0

Thanks, 
Miro

Hi @Miro,

Just realised from the video that your method will not work as we need to show the additional question in the same form. No matter what I do when trying to use the Override flag based on the value of a "Company" using the Group Picker, the additional question won't show.

As a workaround i've created a Static Dropdown List and inputted the 3 Company names into here and it now works. It's going to have to do for now until the Override Flags works with a Group Picker field.

As for the "Site" Data Query field, there is no workaround except to read the "ID" of the Selected Site, and not the name. Not ideal if we were to add more "Other" sites, we would still have to manually update the Progressive Capture and add in the additional ID's which I wanted to prevent.

Thanks,

Samuel

Link to comment
Share on other sites

47 minutes ago, Miro said:

Hi @samwoo,

I'm right now on it and have some things done.
Can't estimate any date as I also need to involve guys from "admin" but work is in progress. 

Thanks,
Miro

Thank you very much for your help @Miro

Samuel

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...