Jump to content

Labels appearing as questions


LawesD
 Share

Recommended Posts

Hello All, 

Since the latest update of Service Manager our labels are appearing in the question fields when they have previously been hidden. 

We have used these for information and titles throughout our self service portal. 

Is there a way to hide these again. 

Example from a test where the top and bottom bullet points should be concealed from the results but visible on the form:

image.png.1f8761ad938e8f3a02349a340c2be688.png

Link to comment
Share on other sites

Slightly unrelated to your question, I noticed that you have a label that describes what I'm guessing is the Progressive Capture Attachment upload form which would follow this custom form.  There is a new feature soon to be available which will let you customise the Attachment form to provide your own title and description so you should be able to remove that second label.  Keep an eye open on the release notes for this.

Regards,

James

  • Like 1
Link to comment
Share on other sites

On 8/29/2018 at 7:30 PM, James Ainsworth said:

There is a new feature soon to be available which will let you customise the Attachment form to provide your own title and description so you should be able to remove that second label.  Keep an eye open on the release notes for this.

Is there any news on when this enhancement will be released please? I've been asked for a Progressive Capture which will be asking for a few mandatory attachments and being able to change the description of each node would be REALLY useful....

thanks

Link to comment
Share on other sites

3 hours ago, Paul Alexander said:

Is there any news on when this enhancement will be released please?

Hi @Paul Alexander

The work on the Progressive Capture Attachment form to allow for a title and description has been completed.  It is now in our release cycle and you should see it in the one of the upcoming Service Manager updates over the next couple of weeks.

Regards,

James.  

Link to comment
Share on other sites

  • 2 weeks later...

Hi all, 

Is there any update or discussion about the visibility of labels in the question field of a request? 

We're seeing more instances of jobs logged with this type of complicating detail that we need to show the customers but do not need in the answers. 

image.png.b5e85e880fe47980af610c14c0b3e229.png

 

Regards

 

Link to comment
Share on other sites

Hi @LawesD

Labels that have a Default Value included will show in the questions.  Have you tried removing the Default Value?

The field Label where I have highlighted Displayed Label is the label to be displayed.  The label was designed to be just that, a short, single line label.

If you have added text in the Default Value this changes the behaviour of the label and assumes that this is information that you do want to store.  I'm not aware of any changes in this functionality since it was added.  

image.png

 

Regards,

James

Link to comment
Share on other sites

Hi James,

Thanks for the response. 

The label field setting of that screen shot is not displayed at all during the progressive capture. The default value is what the customer will see. Before the last update, there was a setting to hide labels in the question field like there is one for hiding unanswered questions. We cannot find this now.

Regards. 

Link to comment
Share on other sites

Hi @Ehsan

Thanks for the reply, does that mean that the mountain of labels I've just spent moving into the description fields are now going to be redundant? :P

Currently I was using a note in the label field so I could see the labels at quick glance in the PCF maker view, then populating the description field with the viewable content. 

 

 

Link to comment
Share on other sites

The solution I found, which I guess may now be a moot point, was actually better than before as the description field allowed me to easily insert large chunks of text with line breaks in as opposed to inserting paragraphs as individual labels - good for disclaimers etc. We haven't pushed the button to update yet, can you tell us if the description field is still going to be visible? I could easily put a little customer facing title to it in the label field. 

Link to comment
Share on other sites

I can clarify with an example.

I have set up a field as below. Notice that the field type is Label and both Description and Default Value fields are presented.

image.png

 

The below is the existing behaviour whereby the Default Value is presented as the label and the Description is presented below it.

image.png

The change in behaviour within the current Service Manager build, shows the Default Value (i.e. the label) in the Questions section and hides the Description (or what was referred as the "answer") when the field type is Label. This change was made to improve the presentation of Label fields in the Questions section.

image.png

Thanks,

Ehsan

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...