Jump to content

Can't change site


Recommended Posts

Hi @Giuseppe Iannacone

I believe that this is to do with the customer that is associated to the request.  It might be restricting the selection of the site to the sites that the customer belongs to.  If there are no sites then you can't select one.  However, I do recall some other posts that mention this.  I'll have a look to see if we have anything planned to change some of this behaviour.

Regards,

James

Link to comment
Share on other sites

This was a previous post from a customer with the same question.  I did locate the change to remove restrictions around the site selection within the description.  I'll also test your scenario, but I'm sure that there will be a relation to this limitation with which this change will fix.

Link to comment
Share on other sites

No estimated time frame at the moment.  It is a minor change so hopefully it wont be too long to get this through.  In the mean time I'm sure that there is a combination of company/site/customer that is needed.  Once set up you should be able to change the site.

 

Link to comment
Share on other sites

1 minute ago, James Ainsworth said:

No estimated time frame at the moment.  It is a minor change so hopefully it wont be too long to get this through.  In the mean time I'm sure that there is a combination of company/site/customer that is needed.  Once set up you should be able to change the site.

 

can you provide more details please regarding the workaround?

Link to comment
Share on other sites

On the Site form in Administration (System->Organisation Data->Sites) make sure that there is a company selected on the site form

image.png

On the Company form, make sure that the user is listed against the company

image.png

You may want to refresh the request form that you are trying to change to make sure it has picked these changes in admin.  You should now be able to change the site.

Regards,

James

Link to comment
Share on other sites

We are also having this issue, and linking all sites to an organisation is not an option for us due to our workforce working across two counties and therefore access is required to all sites at all times.

Please could we ask that this bug is fixed as soon as possible to enable the site change in the 'description' to work ASAP?

Lauren

Link to comment
Share on other sites

39 minutes ago, lokent said:

that this bug is fixed as soon as possible

Just to clarify this, just because something does not work as someone would think it would, does not mean is a bug. "A software bug is an error, flaw, failure or fault in a computer program or system that causes it to produce an incorrect or unexpected result, or to behave in unintended ways." (https://en.wikipedia.org/wiki/Software_bug)

In this case, the system works as designed and behaves as intended. The intended design and behavior is that a site needs to be associated to the customer in the request in order to be available for selection in request details. This was the original thought for this functionality. The change that James mentioned is about enhancing/changing this functionality to remove this restriction of site - customer association as it seems  there are scenarios where this is not necessarily required.

Link to comment
Share on other sites

James will be able to give more details but I’m fairly sure there is no workaround at the moment, other than associating to one company and if I’m not mistaken we already working on a change to improve this and give you the functionality you need.

Link to comment
Share on other sites

21 hours ago, Giuseppe Iannacone said:

how can we manage the change in this occurrence?

do we have to ask a change against the system design?

Hi @Giuseppe Iannacone

As mentioned in one of my earlier comments, we do have a change which will allow you to disable this strict relationship between user and site.  I don't have a definite on the time frame for when it will be available.  As it is something fairly minor, it shouldn't be too long before it is available.

Regards,

James

Link to comment
Share on other sites

  • 4 months later...

The mentioned functionality to allow the site field within the request details to be changed to a site other than the customer's site, is available in the live environment.  A new application setting has been added

app.request.update.site.showAllSites

When enabled, this will provide the option to select any site.

I hope this helps.

Regards,

James

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...