Jump to content

Recommended Posts

I have have created scheduled jobs in Service Manager and initially they worked, but now fail or don't even attempt to run.

We are in the process of migrating from Supportworks to Service Manager and I needed to recreate the scheduled calls that we use for the service desk to complete daily checks etc. Initially I created 2 scheduled jobs which seemed to work fine, so I then decided to disable them until go live, so that I wasn't flooded with activities and created some more. After I created around 30 more (scheduled date and times setup but in a disabled state) I thought it best to retest the first couple. When I enabled them and reset the start time, they failed to run or don't even attempt to run. The logs for these show that the assigned group doesn't exist even though I am able to select it (I've tried various groups). 

Has anyone experienced the same or have a fix for this issue please? I don't really want to have to recreate all of jobs I've already done. Please see the attachments. Thanks

Andy Hodkinson

Scheduled Job - Hornbill - Google Chrome_2018-07-05_15-52-53.jpg

Scheduled Job - Hornbill - Google Chrome_2018-07-05_15-50-20.jpg

Create New Topic - Hornbill Community Forums - Google Chrome_2018-07-05_15-52-25.jpg

_2018-07-05_16-00-17.jpg

Link to comment
Share on other sites

Hi @Victor thanks for getting back to me. I tried reassigning the scheduled job to another team, as well as an individual member, and rescheduled the job to run again,  but both failed to do another. It looks like it doesn't even try as the log hasn't been updated. 

The groups and teams haven't been touched this last year. I re-enabled a few other jobs I had previously created and they also failed to run. It looks like they show the group assignment in the same way. Thanks and I appreciate any help or suggestions you can provide

2018-07-09 12_53_53-Scheduled Job - Hornbill.png

2018-07-09 12_54_21-Scheduled Job - Hornbill.png

Link to comment
Share on other sites

@AndyHodkinsonPrincesIT can you please try something for me?

1. Edit the "Friday" task
2. Remove the current assigned team by clicking on the blue X button.
3. Save these changes (i.e. no team, assigned).
4. Navigate back to "Scheduled Job" list.
5. Refresh the page (using F5 for example).
6. Edit the "Friday" task (again)
7. (the assignment should be empty) - Assign the team
8. Save the changes and navigate back to "Scheduled Job" list.

Let me know when this was done.

Link to comment
Share on other sites

@Victor I have tried the steps above but unfortunately I'm getting the same outcome. 

I have created a new scheduled job and assigned it to a team, which ran without any issues. I also edited the team and time for this and it worked again. 

It looks like the route cause is disabling a scheduled job and then re-enabling it again later, so I will start to recreate these and not disable them, but it would be helpful to find a fix in case we want to temporarily stop any scheduled jobs in the future. Thanks for your help

Link to comment
Share on other sites

  • 5 months later...

Was this was ever investigated further? It is still a problem as when you edit the details of a scheduled job, it breaks it, and it doesn't run again. We have around 30+ scheduled jobs and if we want to edit one, we have to basically recreate it, but when creating new scheduled jobs, I can't go back in and edit it later as the option isn't available. Originally I could do this (even though it would break it anyway, as stated above). Thanks

@Victor

image.png.3f4d833f3493494fa7b7ea06507d6a4f.png

Link to comment
Share on other sites

  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...