Jump to content
Stuart Riddell

Service & Customer Portal contact details revert to Hornbill on non-default languages

Recommended Posts

When setting up the Contact details for the Customer & Service Portals and a new language is added to the system, the details are not copied across.  Consequently, each one has to be changed from the Hornbill defaults to ours.   

image.thumb.png.8ab515c295d10242702df42dfdcd171d.png

 

The only way to do this is:

  1. Login as English (British).
  2. Set up the details on Home > System > Manage Portals > Customise Customer Portal & Customise Service Portal.
  3. Change my language  to the next one in the list.
  4. Log out
  5. Log back in again (in a language that I might not be able to read natively)
  6. Repeat steps 2 to 5 for the next 15 languages.

This is tedious & time consuming in the extreme.  Fortunately, we spotted this before it went live to our Customers but it could have been very embarrassing.

It's not what we would have expected since there are no Language options on the configuration page.  It needs to have the same options as FAQs where the language can be selected & updated individually.  Or at very least, a warning where multiple languages are involved.

 

image.thumb.png.c2344d9076271696bff1b24203037e75.pngimage.png.3a521efcd5f0e9869330514f77d59083.png 

Share this post


Link to post
Share on other sites

@Stuart Riddell apologies for the delayed reply. Upon reading your post I think there might be a misunderstanding of some Hornbill functions mechanism which I also believe are not documented in detail, this would be our fault. You mentioned the following:

On 6/8/2018 at 12:41 PM, Stuart Riddell said:

When setting up the Contact details for the Customer & Service Portals and a new language is added to the system, the details are not copied across.

This is the intended functionality and the reason is simple: there is nothing that can be copied across. I'll try and explain this. When customising the portal (or any other customisable area for that matter), when a language is changed, if there is no configuration (i.e. no existing translation) for that language, because Hornbill does not have a value to put in that field, it will use the default values in all the fields displayed here. This is a general mechanism it applies in all other areas of Hornbill where translation is used.

On 6/8/2018 at 12:41 PM, Stuart Riddell said:

It's not what we would have expected since there are no Language options on the configuration page.

You are right, there should be and this is something our development team implemented. This should be available in one of the next admin tool updates.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...