Jump to content

Inbound routing rule ticket update doesnt email customer


clampj
 Share

Recommended Posts

Hi

I have emails sent from a system account that are automatically added to a ticket as an update but I would like that update to be emailed to the customer.  Not sure how to do this - any pointers?

Probably something simple.

Thanks

J

Link to comment
Share on other sites

Is it a manual action to trigger the sending of that email though?

Basically, I dont want any interaction - once SM has received the email and the routing rule has attached the email to the call I want SM to then email that update to the customer.  How do we trigger the sending of that email automatically?

Obviously when updating a ticket manually you have 2 options, update the ticket which doesnt email or email which also updates the ticket.  Is it possible that the routing action of update is the equivalent of the manual update action and there would need to be an additional routing action of emailupdate which would be the equivalent of the manual email action?

Link to comment
Share on other sites

This is basically the last thing to sort before we can go live with the automated remote access requests - given the weather (and the inevitable flooding our HQ will experience when the snow melts) i'd like to get it up and running as soon as possible!  So close :) 

Link to comment
Share on other sites

Use the Email Notification > Customer node in the BPM.

I use it like this: 

Suspend - Wait status change > <Email received, status/substatus changed from On-Hold to Open-Ticket Updated> <Email notification - Customer>

You will need to set up substatuses on the service and set at least one up to allow auto change on ticket update. 

Capture.PNG

Edited by Dan Munns
Sausage fingers
Link to comment
Share on other sites

@Dan Munns I'm struggling to get this to work despite reading the wiki - mind if I pick your brains a bit more?
Just to confirm I've got the process setup correct, I've inserted 2 nodes into my process, ones an automated task node that i've called "wait for powershell reponse" and set it as below in the screenshot.  I've then connected that to another automated task node to handle the email notification to the customer which includes the variable specified by Victor in an earlier post. I've configured this node as per the below screenshot.


The process doesnt progress past these steps. I've also attached a screenshot showing the sub-status.

What am I dong wrong?

Thanks
J

BPM1.png

BPM2.png

BPM3.png

Link to comment
Share on other sites

You need to set an on-hold substatus. So when the BPM changes the substatus from the on-hold status to the active sub-status the 'Suspend - Wait status change' node will show true and the BPM will continue. 

As you have it set at the moment the BPM has nothing to change as there is no on-hold substatus. Just putting the call on-hold wont work as it looks at substatus to change not main status. 

Also in the top screen shot you need to be changing the status from On-Hold rather than from Open. So you will probably need to put a node in 'Update Request Details - Status' change the main status to On-Hold, change the substatus to your newly created on-hold substatus and then have the 'Wait for Powershell response' node.  

Link to comment
Share on other sites

Still not working :(

I've added an additional node to place the call on hold.  I've configured it as per the screenshot.  If I understand you correctly, I need to change the status to "on-Hold" but as you can see it isnt listed as an option.  The sub status is set to the new sub status i've just created.

Also is there a way to view the full error?  Can only see part of it as the red box that appears isnt big enough to display it all.

BPM4.png

Link to comment
Share on other sites

Frustratingly close now!

Thanks for your help thus far - and very kind of you to offer to check the BPM however I've now managed to figure it out.

Your approach works great - once I figured out that I needed to add "On-Hold" into the bpmrequeststatus list!  Thats why it wasnt appearing in the screenshot above.

The only problem I have now is the content of the email back to the customer.  I've created a template as per victors suggestion (I'm assuming that variable is supposed to pull back the last timeline update) but between the received powershell email timeline update and the sending of the email to the customer, another timeline update appears notifying of the change in sub status and this sometimes appears instead of the received email update in the email to the cusomter.

Any ideas why this might be?  Is there a way to supress the sub-status changes messages?  I cant seem to see any way although I'd imagine thats a global setting and I doubt we would want to switch that off  if so.

Thanks

J

Link to comment
Share on other sites

The timeline update issue. 

8 hours ago, clampj said:

 another timeline update appears notifying of the change in sub status and this sometimes appears instead of the received email update in the email to the cusomter.

 

Link to comment
Share on other sites

OK so the asynchronous execution explains the inconsistency.

Unfortunately the node in quesiton doesnt have any option to surpress the timeline entry - this was the first thing I tried to do.

Any ideas how to overcome this?  Would seem a shame to have to try and do this a different way becasue of inconsistencies.

Thanks

J

 

bpm1.png

Link to comment
Share on other sites

@clampj hmmm ... maybe, maybe... try and put a node (before the email) which suspends the process "Wait for Status change"... have this node to expire after 1 minute.. basically the node is just a placeholder, it serves no other purpose than to ensure everything finishes in the process before the email node... does make sense?

Link to comment
Share on other sites

Yes that makes sense although in the absence of being able to surpress the sub-status timeline message then surely all your suggestion will do is ensure that the customer email consistently contians the sub-status timeline entry and not the one I want?

That is, if my assumption is correct in that the variable: {{RequestLastActivity.H_content}} pulls the previous timeline entry

Can I reqeust a change so the timeline update is configurable for the node pcitured in my previous post?

 

Link to comment
Share on other sites

@clampj 

5 minutes ago, clampj said:

surely all your suggestion will do is ensure that the customer email consistently contians the sub-status timeline entry and not the one I want?

Ermm... doh!!!... yes,. now I've put 1 and 1 together and I understand the scenario... how about "Wait For Update" instead of "Wait For Status Change" ?
 

32 minutes ago, clampj said:

Can I reqeust a change so the timeline update is configurable for the node pcitured in my previous post?

This would be something for @James Ainsworth or @Steven Boardman to advise...

Link to comment
Share on other sites

This is really starting to annoy me now!

I've taken out the sub-status and got rid of the associated nodes and added in a suspend->wait for customer but because of the annoying asynchronous (I'm sure it has its purpose) processing, it takes the timeline entry of the previous node as the required customer response and progresses. Why on earth the BPM is allowed to progress before timeline entries of the previous node have completed is beyond me - is there a design reason for this?

Anyway, I've placed a timer of 2 minutes into the process to allow the previous node to complete updateing the timeline before moving onto the wait for customer node.  Unfortunately this isnt working.  As soon as the timer has completed, the wait for customer node progresses despite there being no further update on the call which result in the customer getting an email continaing the following:

Task '{"RemoteAccess - Process Task", "urn:sys:entity:com.hornbill.core:task:TSK20180302000018"}' was added and assigned to 'Field Support' team

I've attached a screenshot showing the BP and the node config.  I've also included the timeline.  The last entry on the timeline (which is the recevied email) should be appearing between item 3 and 4 on the timeline.

If only timeline entries for sub-status changes were configurable or all node processing, including timeline entries, completed before progressing I'd have this working now.

Please help!  Have I done something wrong or is there a bug? (Rhetorical Q - It will be me :()

bpm1.png

wait for 2 mins.png

wait for powershell.png

email customer previous timeline.png

timeline.png

Link to comment
Share on other sites

OK - I'm an idiot.  Wait for customer means a customer on the call not customer update DOH!

Think i've been looking at this that long i'm going slightly mad - hope it amused someone along the way though :) 

  • Haha 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...