Jump to content
Lyonel

Issue with login / redirection on Service Portal?

Recommended Posts

Hi,

Many of my colleagues and users / customers are reporting a strange behaviour on the service portal. When they click on the link that redirects then to our service portal (https://service.hornbill.com/XXX/servicemanager/request/view/SR00053013 for example), they get redirected to the login page. When they click on the login link, SSO kicks in and they authenticate ok. However, they then arrive on the landing page and many users do not even understand they need to go onto the "My Request" tab... Anyway, is this a new issue? Are you aware of a similar issue from other customers?

Share this post


Link to post
Share on other sites

Hi @Lyonel

If it helps with fault finding I can tell you that we are NOT experiencing this behaviour. 

Tested on Chrome 64, Firefox 58, IE 11 and Edge.

May be an issue with ADFS?

Share this post


Link to post
Share on other sites

@Lyonel

You need to have Auto login Enabled, Administration -> System -> Portals -> Configure Service Portal

Screen Shot 2018-02-19 at 09.29.17.png

Kind Regards

Trevor Killick

Share this post


Link to post
Share on other sites

Thanks @TrevorKillick! Just activated this setting. Will see if it gets better...

We had an issue with our ADFS provider Wednesday last week, which would explain why most users "lost" their login...

Share this post


Link to post
Share on other sites
1 hour ago, TrevorKillick said:

@Lyonel

You need to have Auto login Enabled, Administration -> System -> Portals -> Configure Service Portal

Screen Shot 2018-02-19 at 09.29.17.png

Kind Regards

Trevor Killick

Hi @TrevorKillick

We use O365 authentication....would having this setting (above) set mean that customers would get redirected to the 'correct' page regardless of whether they'd logged in to the Portal previously that day? 

We have had a similar problem to @Lyonel in the past but I haven't really taken much notice of it. We do have 'auto login' disabled at the moment, so I'm wondering if switching that 'on' would stop the problem?

thanks

 

Paul

Share this post


Link to post
Share on other sites

@Paul Alexander

It should do yes, the option essentially prevents the default landing page from showing and automatically takes a user to the login page, it was added to specifically deal with a request URL being embedded in an email so it should stop people having issues clicking links once they have been logged out.

Kind Regards

Trevor Killick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×