Jump to content

Dashboard not updating


Gary@ADL
 Share

Recommended Posts

Hi Guys - we are having a problem with our dashboard charts not updating?

 

we noticed yesterday that the dashboard charts were not displaying the correct information, the numbers changed throughout the day (so it looked like it was working), but actually it is under-reporting the figures,

 

we have found that if you edit the view, then save it, it makes the numbers come right again and stay right, which is a good short term fix, but we are unsure what has caused them to start under-reporting in the first place and so are a bit cautious about using these charts for management reporting again.

 

the specific management reporting dashboards area  (as apposed to the one you access via service manager) has been unaffected and working ok.

 

the only thing we have changed recently is our list of services, but the chart attached below doesn't reference the service, just the ticket status, and which team its with, so I wouldn't have thought a service change would make a difference?

 

thanks

 

first image shows chart before we opened the edit view bit for it, then saved it, second picture after, we have since tested it after, and it seems to be updating in real time again,

 

 

 

 

Capture.PNG

Capture1.PNG

Link to comment
Share on other sites

Hiya - yes they are, accessed via the "switch to my dashboards" button when looking at the request list as a service user,

 

note the dashboards a reporting user (non service user) views seem to be ok and showing the correct information,

 

thanks 

Link to comment
Share on other sites

Hi Victor, we are pressing the update button on the page, (not I.E refresh, the actual "reload charts" button), which is refreshing the charts, and the numbers are changing - but they are not the correct numbers, its like they are missing certain tickets - in order to get the chart to display the correct numbers, we are having to go to the request list screen, edit the view that the chart is attached to, save it, then when we look at it again in 'charts view', it displays the correct numbers, and updates when reloaded etc.

 

as said we have changed our services a couple weeks ago (removed a lot!), so it could make sense that perhaps the charts are only picking up tickets from the services that were present when we created the view. but if this is the case then we'd just like it confirmed so we know for future,

 

context is that our manager uses these figures for monitoring the stats, queue sizes etc, HIS manager uses the reporting user section to view the stats,  Our manager got caught off guard as the figures he was looking at looked ok. whereas the figures HIS manager was looking at were not so great. (as you can see in the 2 charts above, our manager was looking at the first one, his manager was looking at the second one)

 

cheers

Gary

Link to comment
Share on other sites

@Gary@ADL firstly... "our"..."his"... how many managers do you have there? :D No wonder Service Manager gets confused... :P

I'll have a look at the requests from both charts to see where the discrepancy might come. I'll update you once I got the info...

EDIT: ... and sorry, I misunderstood the "auto" update bit :)

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...
On 19/12/2017 at 10:33 AM, Gary@ADL said:

first image shows chart before we opened the edit view bit for it, then saved it, second picture after, we have since tested it after, and it seems to be updating in real time again,

2

@Gary@ADL once again, sorry for the delays on this one... our dev team had a look into the behavior you described and they confirmed that it used to be a defect in SM a while back which made the charts slightly off sync with the custom view causing the updating in real time to break. However, the fix did not apply retroactively (i.e. on charts created before the fix was deployed) so previously created charts will still be affected by the issue. This until the user does exactly what you mentioned above, open - edit - save again, this in effect resyncing the charts with the custom view.

If the issue still persists for you after doing the steps above, please let me know and I will ask our dev team to investigate more.

Link to comment
Share on other sites

  • Victor changed the title to Dashboard not updating

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...