Jump to content

Home View not saving


Paul Alexander
 Share

Recommended Posts

Hello

I have one analyst who can't seem to set his Home View up. He's tried changing the view to one that he wants, and then pressing the 'set current view as My Home' button, when he presses the 'home' icon he's taken to a resolved call.

I can't see where these settings are kept, so could someone point me in the right direction please? 

 

BTW I've tried deleting the browsing history etc in Chrome but this hasn't made any difference

thanks

 

Link to comment
Share on other sites

@ArmandoDM

I've checked the setting in the users' session for "webapp.view.ITSM.serviceDesk.requests.list.view.default" and it is exactly the same as mine.

All he's trying to set up is a view of HIS calls (so he has a filter of Open Requests where the owner is him)

Interestingly (possibly).....if he clicks the 'blue box' beside the Hornbill logo in the top left hand corner, then selects Service Manager, the Request List DOES then filter correctly. However, if he clicks either the Home View button or the Hornbill logo it takes him to this one call (which is NOT what he wants)

Hope that makes sense!

 

Again though, this is just on HIS session...nobody else is experiencing the problem

 

 

Edited by Paul Alexander
Update
Link to comment
Share on other sites

@Paul Alexander

the setting "webapp.view.ITSM.serviceDesk.requests.list.view.default" is the same for everyone, as its the default view if you have no saved any home view.

It will be updated for the specific user when he saves his own Home view.

Let me investigate further as to what might cause this issue  , ONLY for ONE user.

 

Link to comment
Share on other sites

@Paul Alexander think I found what is going on :)

 

Your user is trying to set up a request list view, with open requests where he is the owner. I assume he has a custom "View" configured for this:

image.png

To set up this custom view as Home view, open the custom filter then use "Set Current View as My Home":

image.png

From now on, every time you open the requests list the user will be defaulted to this view. This is how this should be configured...

 

There is another default view in Hornbill which is the application default view, which is the one your user actually configured:

image.png

Your affected user set this while having the request open so now, every time he logs into Hornbill, it defaults to that request. Simply change the "default view" to something else, like "Request List" (open request list then click on "Make this my default view"). Once this done every time he logs into hornbill it will default to requests list...

So, it seems there was a mixup of these:

A. Application (or Hornbill) default view  - set in user profile;
B. Request List default view - set using the steps described above.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...