Jump to content

Asset types when reporting


Guest pproot
 Share

Recommended Posts

Guest pproot

When reporting on assets, the type populates into the reports with a number rather than the asset type (for example laptop becomes '2' in the reports). How do we get the type to populate correctly in the report? Thank you 

Link to comment
Share on other sites

  • 3 months later...
On ‎08‎/‎06‎/‎2017 at 3:44 PM, Victor said:

@pproot if the report is using SQL schema designer you can join up with asset type table to get the type name... or use a CASE in SELECT statement but that needs to be maintained...

Hi @Victor,

Can you clarify how we can use a CASE statement in Service Manager Reporting? I need to convert the numbers for the Asset's Operational State into Text (as well as some other fields) and not having any luck :(

Thanks,

Samuel

Link to comment
Share on other sites

2 hours ago, Victor said:

@samwoo I think I can draft an SQL statement if you send me some requirements, e.g. some examples on how conversion should work and what info (fields) should be in the report....

Hi Victor,

It sounds as if this can only be done via Database Direct... but if you actually mean the Reporting tool in the Service Manager area then i have my fingers crossed in hope that this will be possible.

When I looked at the Entity Viewer it did state that the Operational State field is "currently hard-coded" (which i cant remember where i found this). So i'm hoping that this will change so we can use an actual value one day.

Thanks for looking into this @Victory.

Samuel

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...