Jump to content

Skipping Forms in Pro Cap


Dan Munns
 Share

Recommended Posts

Hi all,

I have made some changes to our new starter procap to add in some new systems and permission levels, however once the top level form is selected the procap skips the next two forms.

If I click 'previous' in the procap it shows the two forms that it has skipped.

The forms are all set to 'Never Skip Form = True' so I don't see why this is happening.

Any help? I have attached the procap form. 

Thanks

new-starter.pcf.txt

Link to comment
Share on other sites

Guest Mohamed

Hi @Dan Munns

Thanks for you query, just so i can understand the issue better, how exactly are you invoking the progressive capture step by step
i.e. Going from the Request List > Raise New > Incident > Form (Press Next) etc.

In addition, would it be possible to provide a screenshot of the Progressive Capture

Thanks

Mohamed

Link to comment
Share on other sites

Ok so trying it again after lunch it works fine if I start the procap via the service portal but still doesn't work correctly if I set off the procap from Request List > Raise New > Service Request > Staff Changes > New Starter.

I have no idea why it has started working in the portal as I haven't changed anything but got confirmation from the application owner that the form was working ok in the portal for them so I tried it again and it works for me also.

 

Link to comment
Share on other sites

Guest Mohamed

Hi @Dan Munns

Thanks for that, I've used the PC form that you provided, however as i press next on each form it works correctly as it should, without skipping

How exactly are you calling the Progressive Capture i.e. Raise New Button or Raise Incident button etc. or is it via a Catalog selection? 

Thanks

Link to comment
Share on other sites

It works ok if I go through the service portal to start the form.

If I select Raise New > Service Request > Staff Changes > New Starter from the hornbill.live view it skips.

I have attached the procap option I selected.

It has missed the permissions form under Aurius and it has missed the Respond permissions form as well.

 

 

 

Untitled1.png

Link to comment
Share on other sites

Guest Mohamed

Going from 'Raise New' > 'Service Request (Option)' > Staff Changes , what is this, i can't see it on the PCF that you provided, is it another custom form or catalog or something?

Thanks

Link to comment
Share on other sites

Guest Mohamed

Sorry yes that is what i meant, that you select the Service Request option from Raise New
Thanks for clarifying that 

May i ask, does your Service Request PC have a switch node in place?
switch.JPG

Thanks

Link to comment
Share on other sites

I don't have a service request PC. The PC I have posted doesn't have a switch node in it.

It all worked fine until I added the extra forms in for permission levels for the two applications.

Thanks

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...