Jump to content

Release request - Details section


Guest Sonali
 Share

Recommended Posts

Guest Sonali

Hi 

I am trying to hide some of the fields within the details section of the release record. I am un-selelcting the eye and then saving the changes but this is not working.

Please can you help me.

Sonali 

Link to comment
Share on other sites

Hi Sonali,

There are two different access points for modifying the details section of a request.  The details section can be configured to be unique for each individual service or a request not associated to a service can use a standard default form.  You may find that if you are saving the form it may be for a particular service only and it will not apply to all requests.

To modify the details form for a request that will be related to a particular service, navigate to the Services option under the Service Manager menu.  Select the service where the request will be used.  Select the request type and click on the ''View Details Form''.

viewdetailsform.PNG

Modifying a form from within a service will only affect requests that have been associated to this service.  

Another way of modifying a form is to open a request record and click on the design button within the details section of the request.  It is important when doing this that you make a note of the service that is associated to the request that you are modifying. The changes that you make here will only be available for requests that fall under that same service.  If you are modifying a request that has no service, this will be modifying the default form.  The changes to the default form will not be visible on a request that is associated to service with a modified form.  

  designinrequest.PNG

 

I hope that helps.

James

Link to comment
Share on other sites

Guest Sonali

That's great but when I go into the default form to amend the form and then click apply changes - it doesn't apply the changes and goes back to the original settings.

Link to comment
Share on other sites

Guest Ehsan

Hi @Sonali

Could you please confirm if you're assigned the "Form Designer" Role? This can be found through Admin Tool > System > Organisation Data > Users > [Click on the hyperlink for your Login Id] > Scroll down to Security Settings > Roles section.

Thanks,

Ehsan

Link to comment
Share on other sites

Guest Ehsan

@Sonali To help us investigate this further, is it possible if you could help me debug this further.

Through Chrome...

1) Open a Request > Click on the "Design" button within Details section

Screen Shot 2017-05-02 at 13.59.41.png

 

2) Hold "Ctrl + Shift + I" on your keyboard. This will open the Chrome Developer Tools (it may positioned at the bottom of the page rather than on the right hand side). Your window should look like the following screenshot. Click on Network tab (pointed out in the image with a red arrow). Then click on the clear button (pointed out with a second red arrow).

Screen Shot 2017-05-02 at 14.02.45.png

 

3) Make your changes and then click on "Apply Changes".

In the Developer Tools, click on "?method=appOptionSet" (pointed out in the image with a red arrow) and then click on the Response tab (pointed out in the image with a red arrow). Please provide us with the content of this tab - a screenshot would suffice.

Screen Shot 2017-05-02 at 14.06.58.png

 

Thanks,

Ehsan

Link to comment
Share on other sites

Guest Sonali

Hi

I got up to step 3 and couldn't find "?method=appOptionSet". Not sure what I am doing wrong

Sonali

Link to comment
Share on other sites

Guest Sonali

{
    "@status": true,
    "params": {
        "optionIsDefault": [
        ]
    }
}
 

Link to comment
Share on other sites

Guest Ehsan

@Sonali OK, this proves that the customisation is correctly applied. Perhaps we should take a step back a little.

I recorded a video a while back, to step through creating a Custom Field for a Service. When you've configured a Custom Field in a Service, you then need to make sure that you're viewing a Request that is raised against the Service. What might also help is, if you could please provide us the details (with screenshots) of the step by step changes that you're making - This may help us to narrow down the problem.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...