Jump to content

clean utility error


lee mcdermott
 Share

Recommended Posts

Hi,

We are due to go live on Monday, so wanted to run the clean utility early to make sure all is well. However I get the following error

 

also conf file attached.

I tried initially to do just change requests, then problem. But it failed with the same error. So went for all requests but still got the same.

 

Any ideas?

clean utility error..PNG

clean utility conf.JPG

Link to comment
Share on other sites

@lee mcdermott I am not an expert at all with this ( @TrevorKillick  usually is the master in my personal experience) but I was reviewing the source code of the utility (https://github.com/hornbill/goHornbillCleaner/blob/master/hornbillCleaner.go) and here is the piece of code failing:

58e39729e3e08_cleanupgo.png.0e6f134ed52c4967ff90b650cf4f1911.png

If my understanding is correct, something went wrong when executing the SQL statement to count the number of records. This is done via the API method "sqlQuery" under data:

https://eurapi.hornbill.com/northumberlandcc/xmlmc/data/?op=sqlQuery

Which makes me wonder: did you change the rights of the admin account? Last time I had a similar message was because I removed a role from the admin account by mistake.

 

  • Like 1
Link to comment
Share on other sites

Hi @lee mcdermott

This is most likely due to the following system setting being set to off:

security.database.allowSqlQueryOperation

With this set to Off, the sqlQuery API is disabled by the platform. Switch this setting to On for the duration of the clean, before switching it back to Off again when the clean is complete.

Hope this helps,

Steve

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...