Jump to content

app.requests.defaultBPMProcess.problem


Guest Sonali
 Share

Recommended Posts

Guest Sonali

I have amended the following setting with service manger to use a particular BPM that we have created: app.requests.defaultBPMProcess.problem

However the system is ignore this and using the default value - Example Hornbill Problem process

I am missing something here? Do I need to change something else as well?

Link to comment
Share on other sites

Hi @Sonali

I have just checked and as @lyonel says, if the name (ID) matches then this should be functioning as expected. you can check that Business Process ID from the Manage Process Settings (top right) in the business process designer.

Screen Shot 2017-03-29 at 22.00.01.png

One thing you could possibly check, is if in your logging process (using Progressive Capture) if you are using the Services Details form as shown below?

Screen Shot 2017-03-29 at 21.42.59.png

If you are, and a Service is being selected, then you may want to check the default Business Process which is invoked if the Problem is logged against a specific service.

You will see that the default business processes maybe 'Example Hornbill Problem Process' which may explain why you are seeing the behaviour you are?

Screen Shot 2017-03-29 at 21.44.42.png

The logic here is:

1. Check if a Service is associated to the Problem on creation.

2. If a service Exists, check and use the Business Process if it is configured in the Services Request Configuration for the selected Service (as shown above)

3. If no Business Process is configured against the Service, then don't invoke a business process

4. If no Service is associated with the request then use the business process (if set) under the app.requests.defaultBPMProcess.problem app setting. 

I hope this helps, and i can see this maybe repetitive of some of the advise above, but let us know if you are still having an issue

Steve

Link to comment
Share on other sites

Hi @Sonali,

When creating a new Workflow, its ID will be the Workflow Title, all in lower case, and any spaces replaced with hyphens. So, unless you've used underscores in your Workflow Title, your Workflow ID to populate that setting should be:

camelot-standard-problem-bp-v1

Rather than the one in your screenshot above.

Let us know how you get on with this.

Kind regards,

Steve

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...