Jump to content

Search the Community

Showing results for tags 'autoresponder'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Hornbill Platform and Applications
    • OpenForWork
    • Announcements
    • Blog Article Discussions
    • General Non-Product Discussions
    • Application Beta Program
    • Collaboration
    • Employee Portal
    • Service Manager
    • IT Operations Management
    • Project Manager
    • Supplier Manager
    • Customer Manager
    • Document Manager
    • Timesheet Manager
    • Live Chat
    • Board Manager
    • Mobile Apps
    • System Administration
    • Integration Connectors, API & Webhooks
    • Performance Analytics
    • Hornbill Switch On & Implementation Questions
  • About the Forum
    • Announcements
    • Suggestions and Feedback
    • Problems and Questions
  • Gamers Club's Games
  • Gamers Club's LFT

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start








Website URL





Found 8 results

  1. This was working fine until this weekend without any changes that I am aware of. The BPM issue is a follows "Status : Failed Last Updated On : 09 Nov 2020 08:57:56 Xmlmc method invocation failed for BPM invocation node 's1/flowcode-b0352867-2f33-4f4c-804e-b6b6d6a26918': <methodCallResult status="fail"> <state> <code>0200</code> <service>apps</service> <operation>notifyEmailCustomer</operation> <error>FlowCode Exception (com.hornbill.servicemanager/entities/Requests/fc_bpm/notifyEmailCustomer): nodeName: Exception; nodeId: acd1ebbe-1cd9-4aed-bf14-50ce53f9a013; At 317/1: &quot;Uncaught FCSException: The email template specified is invalid. Please contact your Hornbill Administrator. More details: EspMethodCall::invoke: Operation[mail::sendEntityTemplateMessage] Access token session mismatch&quot; throw(e); _fc_node_exec_acd1ebbe_1cd9_4aed_bf14_50ce53f9a013</error> </state> </methodCallResult>" I am not sure why the BPM is failing to find the Email Template. If logged via "Self Service" or "Analyst" it works fine. Please see screenshot of BPM failing inside the "Manage Executed Process" If I restart the BPM on the case without any changes it will work fine so I know the BPM works fine.
  2. Hi, when Customer replies to an email sent by Analyst from the Request in Hornbill - it appears on a Timeline as "System AutoResponder". There is an option/button called "Reply". When I click on it I got @System AutoResponder as a recipient. As a result - should the Customer get an email or notification only? See the picture. Thanks, Daniel
  3. in the example below the autoresponder has correctly processed with an email rule routing and the email has been added to the request, but it is visible only for the team, how can i change this default behaviour to customer instead I was trying with the settings "guest.ui.app.com.hornbill.servicemanager.operation.defaultVisibility" but I don't think is the right one
  4. When there are routing rules configured to process an email to raise a request or update a request, there are occasions when these actions are not performed. There are a number of possible reasons why this occurs. Firstly there has to be a routing rule configured in admin tool that will match the email properties (as configured in the rule expression) and the routing rules must be enabled (turned ON) The email sender does not exist in the system either as a co-worker/internal user or a contact/external user. In this scenario, one reason why the email fails to be processed by the routing rule is if the app setting to allow updates from unknown sources is turned OFF and the app setting to send back a rejection email is turned OFF. The email sender does not exist in the system, either as a co-worker/internal user or a contact/external user. Similar scenario as above, another reason why the email fails to be processed by the routing rule is if the app setting to allow updates from unknown sources is turned OFF and the app setting to send back a rejection email is turned ON but either the app setting for rejection mailbox and/or email template is incorrect or not set. The email sender exists in the system but the from address is matching more than one user/contact in the system. (see notes for more information) The request has status closed. In this scenario, the reason why the email fails to be applied to the request when processed by the routing rule is if the app setting to allow updates on closed calls is turned OFF. *[Only for routing rules configured for UPDATE] The application settings can be found in admin tool (Home - Hornbill Service Manager - Application Settings) as follows: allow updates from unknown sources: app.email.routing.rules.unknownUsers.allow send back a rejection email to unknown users: app.email.routing.rules.unknownUser.sendRejectionEmail rejection email template: app.email.routing.rules.unknownUser.email.template rejection email mailbox: guest.app.requests.notification.emailMailbox allow updates on closed Service Requests: app.email.routing.rules.allowClosedCallUpdates.SR allow updates on closed Incidents: app.email.routing.rules.allowClosedCallUpdates.IN Routing rules can be turned ON/OFF in admin tool using the option available in Routing Rules section (Home - System - Email - Routing Rules) or via the mail.autoresponder.enable system setting (Home - System - Settings - Advanced) Notes: to check if the address of the email sender is associated to more than one user or contact in the system you can a report. Here are 2 examples of report definition files on user accounts and contacts (these can be uploaded in your instance). When run, the report will prompt the user to type in the email address and teh report will return all records for users or contacts having that email address. user-list-per-email.report.txt contact-list-per-email.report.txt
  5. Hi all, I have setup a rule to automatically update requests when an e-mail is received. It seems to be working fine but sometimes it does not and I don't understand why... Here is the rule setup: The email address in the rule expression is the correct one. But for example, the following e-mail was not processed properly: For information, at the time the email was received, the request was still opened. Also, when I run the regexp it works perfectly as the request number gets properly extracted from the subject. I also did some test using my personal gmail address. I receive the e-mail from Hornbill. But when I reply, the email arrives in the mailbox but the rule fails. Am I missing something here? Has anybody experienced something similar? Note: I have seen Gerry's post about latin character sets and this answers some of the cases where the auto update does not work. But not the rest
  6. Hi, Just a small one, but a bit strange. The email address that tickets have been sent by has changed from: Request has been logged from Email by: System AutoResponder To: Request has been logged from Email by: System Initialization This isn't a big deal, but we'd like to know how it changed, as we had some reports configured to pick this detail up.
  7. Hello, We've noticed that replies to a Request apply to the Request's Timeline as an update made by "System AutoResponder". The default Visibility for these Timeline updates appears to be "Customer" which means the Request Customer can see any / all replies to the Request. This is an issue for us. For Audit/ tracking purposes we try to send all of our email from the Request, (i.e. if we need to email a 3rd Party we'll do it from the Request so we've a log of what was said) however we don't always want this visible to the customer. Can we have the ability to change the default visibility of the "System AutoResponder" Timeline update? Please note: when i logged in as the System Admin account i was able to manually change the visibility of the email "System AutoResponder" Timeline update however we cannot do this for every update. Regards, Jamie
  8. James I've taken your advice and posted this as a separate topic I'll look at the routing rules both in Hornbill and Exchange, but fundamental I don't agree with the way Service Manager deals with team notifications. I understand the reason for having it (a ticket has no owner, a customer update needs to be seen), but it should be configurable to either: Sent to all team (and sub team members) as it currently does - I don't like this, as nobody takes ownership. And may not be relevant to the sub teams. Ticket timeline gets updated with out of office responses from analysts in the teams (which the customer may be unhappy seeing). This is a bigger problem if you have large teams. Sent to a named individual (eg. team leader or manager). This is what I would prefer - so its clear who monitoring these types of updates (for tickets with no owners). No action to be taken The out of office updates are happening as expected - they are not coming from one individual, but may start initially with the customer, but as the team notification gets emailed to the whole team, any analysts who have their OOO enabled causes the ticket to update, which in turns sends a further notification out. Its not a broadcast storm - but can be annoying if you have nothing to do with the initial team (sub team - eg. main team is infrastructure, server and network are subteams both get notified for an ownerless ticket in either subteam or main team). See previous history here
  • Create New...